Multiple PHP Versions Documentation Is Only For End-of-Life Version (7.0)

The documentation at:

https://www.virtualmin.com/documentation/web/multiplephp

refers to PHP 7.0 which reached end-of-life support 12/2018.

Status: 
Active

Comments

Title: Multiple PHP Versions Documentation Is Only For End-of-Life Version (7.0) and Fails To Describe Updating Existing Sites To New Version ยป Multiple PHP Versions Documentation Is Only For End-of-Life Version (7.0)
Body: View changes

Howdy -- thanks for the heads up!

You're right, we do indeed need to modify that to show PHP 7.1 and 7.2, and remove any references to PHP 7.0.

I would HIGHLY recommend your instructions use the SURY repo for Ubuntu.

I have successfully used the SURY repo for PHP 7.3 and 7.2 on Debian, however it does not have GD available for PHP 7.3 yet. Virtualmin picks up the alternate versions fine.

Any movement on how to add php 7.3 on either Ubuntu 16.04 or 18.04 LTSW versions? so far trying toa dd 7.3 to my 18.04 server bombs apache in a way it refuses to start and virt cannot handle it either.

yeah i have tried that twice and bombed the system so badly i had to restore from backup.

Yeah the php7.3 and related packages from that same PPA should work.

We do need to update those docs to include that though... we'll be doing some testing and adding that to the docs soon.

on every machine i have tested them on it bombs apache to the point I have to restore from backups.

can you be more specific? "bombed the system" is a little ambiguous. I have 5.6, 7.0, 7.1, 7.2 and 7.3 all running on my systems using the sury repo.

Apache crashes and refuses to start. Something gets chagned in the mail apache.conf file. This past time when i removed the offending line all of the virtual hosts disappeared when apache started.

I instlaled the ppa and installed 7.3. I then re-ran the configuration checker. The system hung at regenerating missing ini files. This past itme i let it sit for ore than 3 hours...I know somehting went bad when one of my clients claled saying he was getting forbidden to access errors. This led down a rabbit hole to where i am at again..restoring from backups. My experience isn't unique in terms of my years with virt...I have jsut accepted that virt isn't stable enough to be modifided without extreme risk to the system. If i ran it in any way that modified it outside what we are supposed to be able to do I could understand it...but i have had virt bomb on me more than once while trying to simply do things within it's box as well....

This is exactly why we are looking at switching to real containerization. We have a bunch of vmin server including 3 or 4 pro licenses but it seems that PHP is always the problem for vmin.

php is an huge issue on ubuntu for virt...virt has other issues on centos 7. I am going to be putting my virt installs into a vm so when it bombs...i can flip back to a snapshot.

a REAL solution to the issue would be for vmin to endorse a specific repo (like SURY) so there is no fracturing of the platform. Stick with one repo and make sure it works.

https://deb.sury.org/

what REALLY needs to happen..and i have told them this..they need to add the newer php versions to their own repo that they maintain...The same goes for things like mysql. The time for relying on the os repos alone is past as things now move too quickly(especially for security) to rely on the long term branches to keep up..which they won;t. Centos 7 does not go past older mysql and ancient php versions..same is apparently true for ubuntu lts as well.

or support the faster ring Ubuntus as well...same for fedora.