Root user now has no modules. I can' do anything but look at a blank dashboard.

For some reason, I was getting permission denied on all my vhosts except for new sites I created. I was trying to assign a vhost to my server so I could access it via webmin.mysite.com as I've done dozens of times. (I keep reinstalling because I keep trying to get KVM working in Cloudmin but that's a separate issue).

I figured since I could create a new site and have access to it, why not delete and recreate the sites that are giving me the "Permission Denied you don't have permission to access / on this server." I thought it would help fix the permissions. It didn't. Now when I log in as root, I get a blank dashboard. No virtualmin, no cloudmin and no modules. (See attached image.

I have the server pretty dialed in and don't want to reinstall yet. Please help.

Status: 
Fixed (pending)

Comments

What does the root: line in /etc/webmin/webmin.acl contain on your system?

root=/home/webmin

That's an unusual line ... can you post the whole /etc/webmin/webmin.acl file here?

Thanks for helping me out with this Jamie. The full contents of the webmin.acl file below:

rpc=0 gedit_mode=2 negative=1 uedit_mode=5 feedback=0 readonly= gedit=webmin desc_virtual-server=Virtual Email fileunix=webmin uedit=webmin root=/home/webmin

Hmm, it looks like a user named "webmin" got created, which should never happen!

As a quick fix, try replacing that file with just the line :

root: *

That worked! Thank you!!!

I have all of my modules back. I haven't checked everything else yet.

Would this work if I removed the "webmin" user and added an asterisk to the root: line in the original webmin.acl?

I'm in but Apache and MYSQL aren't working. I'm going to try removing the webmin user and adding the * to the root line in my original webmin.acl

Ok. Removing the webmin user and adding the * to the root line in my original webmin.acl did not work.

What goes wrong with the MySQL and Apache modules exactly?

Jamie, unfortunately I had to start over and reinstall. I have another server I can use to replicate the issue if needed.

I think I broke everything by creating a user named webmin. I'll make sure not to do that again.

Thanks, I appreciate you helping out with this.

Status:
Active
»
Fixed (pending)

Virtualmin should already prevent you from creating a user called "webmin", but it's possible that we missed some cases. We will add additional lower-level protection for this in the next release.