No line for ssl when create new virtual server

3 posts / 0 new
Last post
#1 Wed, 04/17/2019 - 13:33
Havouza

No line for ssl when create new virtual server

Hi! Installed Virtualmin on a fresh ubutu 18.04 LTS. Now when I want to create the first virtual server I cant enable the ssl. The link in Enabled Features is missing. What can I have done wrong?

Anders Yuran

Thu, 04/18/2019 - 15:29
adamjedgar

When you created the virtual server, did you also check SSL website.

As your main webmin server administrator, check virtualmin>edit virtual server>enabled features. There you will find an checkbox option "Apache SSL website enabled". Make sure it is selected.

Normally this should also be setup when you create the virtual server template used to make virtual servers...No big problem doing it here though.

Don't forget this will setup a "self signed" SSL certificate which will throw browser warnings. To get rid of those warnings you need to either purchase a certificate or use a let's encrypt one, and install that onto your server. This is done in Virtualmin>server configuration>SSL Certificate

Hope this helps. Kind regards Adam

AJECreative is the home of $5 webhosting, $15/month VPS servers (1cpu,1gb RAM, 25GB storage)
Centos7, Debian9, or Ubuntu18LTS
Available Control Panels = Centos-Webpanel, Cyberpanel, or Virtualmin

https://ajecreative.com.au

Fri, 04/19/2019 - 03:17
Havouza

I am not sure but there was many problems when I installed on a Ubuntu 18.04 server. I just gave up and installed Centos 7 instead and now it seems all these problems disappeared . Perhaps because I am long used to Centos I really dont know. To answer your question the SSL line was just not there when I created a new virtual server

Anders Yuran