Sharing my adventures upgrading Ubuntu 14.04 to 16.04 with Virtualmin

3 posts / 0 new
Last post
#1 Sat, 04/27/2019 - 05:27
servertech

Sharing my adventures upgrading Ubuntu 14.04 to 16.04 with Virtualmin

14.04 reached EOL last weekend so I decided to upgrade. It went pretty smooth except a problem with PHP - all PHP pages were just downloading sources. For example, phpinfo.php displayed in browser:

< ? php
phpinfo();
? >

instead of the actual server info.

Long story short, removing mod_php helped:

a2dismod php7.3

sed -e "/^php_admin_value.*/d" -i /etc/apache2/sites-available/*.conf
sed -e "/^php_value.*/d" -i /etc/apache2/sites-available/*.conf

Then I got error 500 for some sites still on php5 (to be upgraded soon!). There was nothing in the logs but I figured it out: the name for php5 cgi handler file changed.

# cat /do.sh
chattr -V -i $1
sed -i.bak -e 's#/usr/bin/php5-cgi#/usr/bin/php-cgi5.6#g' $1
chattr -V +i $1

# find /home -name php5.fcgi -print -exec /bin/bash /do.sh {} \;

I hope it helps someone - I'm upgrading to 18.04 when I get everything to work in 16.04

Sat, 04/27/2019 - 06:36
servertech

16.04 -> 18.04 was almost flawless, except for OpenDKIM, which was solved by the accepted answer here: https://serverfault.com/questions/847435/cant-change-opendkim-socket-in-...

Sat, 04/27/2019 - 19:45
jimdunn

All my hats off to ya... I usually have trouble with those in-place production upgrades...