Your system only has PHP version 7.2.17 installed, so selecting a different version for each directory is not possible.

4 posts / 0 new
Last post
#1 Sat, 05/04/2019 - 04:35
Havouza

Your system only has PHP version 7.2.17 installed, so selecting a different version for each directory is not possible.

Hi as you can see from

root@host-thirty:~# php -v PHP 7.0.33-7+ubuntu18.04.1+deb.sury.org+1 (cli) (built: May 3 2019 09:57:22) ( NTS ) Copyright (c) 1997-2017 The PHP Group Zend Engine v3.0.0, Copyright (c) 1998-2017 Zend Technologies with Zend OPcache v7.0.33-7+ubuntu18.04.1+deb.sury.org+1, Copyright (c) 1999-2017, by Zend Technologies

I have php 7.0 enabled on my Ubuntu 18.04 server. Php7.2 is disabled. But Virtualmin dont see this somehow and still tell me that I only have 7.2. We have apps in our webshop that dont work with 7.2

How can this be fixed??

Sat, 05/04/2019 - 19:03
andreychek

Howdy,

You may want to try going into System Settings -> Re-Check Config, that will get Virtualmin to re-evaluate what PHP versions are on your server.

-Eric

Tue, 07/09/2019 - 05:31
tobo

After performing this step, I am still getting the same message. Is there another way to force the PHP version for an existing (sub) server?

thanks!

Tue, 07/09/2019 - 06:07
Havouza

I just got tired of it and installed a earlier version of Ubuntu, (16.04) to get the correct php version for my needs

Anders Yuran