Virtualmin installation now installs SCL PHP 7.2 on CentOS

4 posts / 0 new
Last post
#1 Wed, 06/05/2019 - 00:48
Joe
Joe's picture

Virtualmin installation now installs SCL PHP 7.2 on CentOS

Howdy all,

When we added PHP 7 support to the installer, SCL had PHP 7.0 available. That version has reached end of life, and SCL now provides 7.2 (and 7.1, but no reason to use it, except for rare compatibility issues), so we've switched. We've had documentation for installing 7.2 manually for some time, but I haven't had time to make the changes in the installer and test it until today.

As part of that change, I added a new group to our yum groups, which makes it easy-ish to install all of the usual PHP packages for existing installations if you want to switch. Now, instead of individually specifying the packages you want, you can run yum group install 'Software Collections PHP 7.2 Environment'

SCL packages can coexist side-by-side, so you don't need to uninstall the system-provided PHP 5 or the earlier PHP 7.0 packages. Virtualmin allows you to choose the preferred version on a per-domain and server-wide basis.

As always, let us know if you run into any problems. If you're a Pro user, you can open a support ticket, or if you're a GPL user, you can post a new topic in the forums.

Cheers,

Joe

Sun, 07/14/2019 - 09:51
adamus007p

Is it works for Debian too? What is a command for Debian? Any ETA for Debian 10 support?

Sat, 07/27/2019 - 00:56 (Reply to #2)
Joe
Joe's picture

No, there are currently no changes to PHP support on Debian. We're working on Debian 10 support, but I don't have an ETA.

--

Check out the forum guidelines!

Thu, 07/25/2019 - 02:48
drguild

I need the debian command for php 7.2 as well wondering if Debian 10 is supported as I would like to update once things are stable..