Error when requesting Let's Encrypt Cert

2 posts / 0 new
Last post
#1 Tue, 06/11/2019 - 18:03
Hans

Error when requesting Let's Encrypt Cert

Hi,

this is a first, as adding Let's Encryt Certs works usually flawlessly on our other boxes w. virtualmin...

Requesting a certificate for  [list w. domain names and alias domains goes here...] from Let's Encrypt ..
.. request failed : Web-based validation failed : Failed to request certificate :
Traceback (most recent call last):
  File "/usr/share/webmin/webmin/acme_tiny.py", line 250, in <module>
    main(sys.argv[1:])
  File "/usr/share/webmin/webmin/acme_tiny.py", line 246, in main
    signed_crt = get_crt(args.account_key, args.csr, args.acme_dir, args.dns_hook, args.cleanup_hook, log=LOGGER, CA=args.ca)
  File "/usr/share/webmin/webmin/acme_tiny.py", line 196, in get_crt
    log.error("{0} challenge did not pass: {1}".format(domain, challenge_status['error']['detail']))
UnicodeEncodeError: 'ascii' codec can't encode character u'\u0103' in position 256: ordinal not in range(128)

As I never worked w. the Python , I do not have the slightest idea on how this could be solved :D

An IP belonging to Let's encrypt did show up in the logs though...

Please help, cheers! :)

Tue, 06/25/2019 - 02:21
BBuchanan1013

I get that sometimes, my solution (because I don't know your list) is to actually not include the autoconfig's. Usually autoconfig and autodiscover (which are only used for mail clients to automagically setup). Use the field below that and put in your domain.tld www.domain.tld and mail.domain.tld