SSL: This server does not support Forward Secrecy with the reference browsers.

2 posts / 0 new
Last post
#1 Sun, 06/23/2019 - 23:07
oguruma

SSL: This server does not support Forward Secrecy with the reference browsers.

I used the standard LetsEncrypt Module in Virtualmin. I ran the SSL Labs checker and I got a B. Reason given is "This server does not support Forward Secrecy with the reference browsers. Grade capped at a B."

I have used LetsEncrypt for Apache Webservers before, and I have never had this issue. Can somebody point me in the direction of how to enable this feature?

Mon, 06/24/2019 - 00:24
adamjedgar

AJECreative is the home of $5 webhosting, $15/month VPS servers (1cpu,1gb RAM, 25GB storage)
Centos7, Debian9, or Ubuntu18LTS
Available Control Panels = Centos-Webpanel, Cyberpanel, or Virtualmin

https://ajecreative.com.au