Why is Virtualmin not getting/showing the correct Operation System after Debian update?

6 posts / 0 new
Last post
#1 Mon, 07/01/2019 - 10:14
Karl

Why is Virtualmin not getting/showing the correct Operation System after Debian update?

I dist-upgraded a working system from Debian 7 to Debian 8 and then to Debian 9 (in 2 steps). But Virtualmin is not showing/getting the correct Operation System now, it still shows "Operating system: Debian Linux 7.1", but the system runs on Debian GNU/Linux 9.9.

My system:
Webmin version: 1.900
Virtualmin version: 6.06-2 Pro
Kernel and CPU: Linux 3.10.9-xxxx-grs-ipv6-64 on x86_64

Do you recommend uninstalling and re-installing Virtualmin?

Mon, 07/01/2019 - 16:28
andreychek

Howdy,

I wouldn't recommend reinstalling, that's likely to cause some trouble.

To update the OS, if it's not prompting you to update, try going into Webmin -> Webmin -> Webmin Configuration -> Operating System, and there you can correct the detected OS/version.

-Eric

Fri, 07/05/2019 - 11:08
Karl

Of course I can change it manually. But it doesn't make any sense. I have changed it to the correct Debian version 9.9, but now I getting a warning on the dashboard:

Warning!
Warning - Your system is actually running Debian Linux version 7.1.

Fri, 07/05/2019 - 12:35
andreychek

Hmm, just to verify, can you paste in the contents of the /etc/issue file, along with the contents of /etc/debian_version?

Thanks!

-Eric

Fri, 07/05/2019 - 16:35
Karl

Here's it. The /etc/issue file is quite an old file, from 2013, and not updated:

Debian GNU/Linux 7.1
Linux ks329xxxx.kimsufi.com 3.10.9-xxxx-grs-ipv6-64 #1 SMP Wed Aug 21 11:51:59 CEST 2013 x86_64 GNU/Linux
server    : 29xxxx
hostname  : ks329xxxx.kimsufi.com
eth0 IPv4 : 5.135.xxx.xxx
eth0 IPv6 : 2001:41d0:x:xxxx::1/128

There's a newer file "/etc/issue.net":
Debian GNU/Linux 9

The "/etc/debian_version" file:
9.9

Fri, 07/05/2019 - 17:29
andreychek

I suspect that's the problem... normally the issue file is updated during an OS upgrade, but it looks like the one there still refers to the older OS.

You may want to try copying the issue.net file over top of the issue file, and see if that helps.

You may then need to restart Webmin and then re-log in to get it to detect the upgrade.

-Eric