Replace mariadb with mysql 5.5

Hi, is there a chance to replace within a working virtualmin installation mariadb with mysql? An application vendor insists to change over, otherwise they wouldn't support my installation and they also say, that MariaDB will cause a lot of problems within the upgrade process i am currently working on.

It does not make any sense discussing with the application vendor about this; the according mysql version (5.5 at time being for that specific application software version) is a system requirement i cannot get around.

So is there a chance to replace mariadb with mysql and how would i manage that?

Or would it be an option to give the user the decision while running install, whether he would like to use MariaDB or MySQL? just my 2cts. In some cases like mine you need to stick to MySQL...

Best

j_m

PS: There are a couple of tutorials for that, like this: https://code.trev.id.au/centos-7-remove-mariadb-replace-mysql/ but i just wanted to know, whether there is a "virtualmin-style-way" so i do not break everything... :-)

Status: 
Active

Comments

Howdy -- thanks for contacting us!

Unfortunately, it's pretty likely that you'd run into issues in trying such a switch... we generally recommend against folks changing the MySQL version that comes with their distro, especially on an already running system.

The instructions you shared there has you pulling in packages from the MySQL community repository, which is a third party repository (that is, the packages aren't coming from CentOS). A lot of folks have seen issues when trying to do that switch.

It's not that it can't work, but we can't recommend it, and unfortunately couldn't provide support for it.

If at all possible, our recommendation would be to switch to a distro that provides the MySQL version you need. For example, I believe both Ubuntu and Debian are still shipping with MySQL rather than MariaDB.

Another option might be to setup a small remote database server running just the database type you're looking for.

Or you could always move just this one app to a new server running Ubuntu/Debian and leave everything else as-is.

If you do wish to try changing the MySQL version on your server -- I'd definitely recommend making a snapshot of the entire server first, and you may want to try and perform a similar procedure on a test server first (one that's running the same CentOS version, and has a couple of databases already setup so you can see if any issues arise).

Well, since CENTOS 7 is the only distro with PHP 5.4 still suppporting, and my sysreqs are PHP 5.3.21 or later or PHP 5.4, Apache 2.2 or 2.4 and MySQL 5.5 or 5.6... Hard to find a distro still supporting this. I thought i could get it done with CENTOS whereas i usually live in debian / ubuntu world, and everything seemed fine until with the first upgrade i ran into collation issues due to that it was maria not mysql. ...

I will give it a try with a docker mysql 5.6, perhaps this might do the trick. Wasn't on my mind, that this could be a viable workaround.

Thanks for your advice.

Best j_m

Yeah if you need PHP 5.4, CentOS 7 is definitely your best bet there.

Using Docker is indeed a good idea, and would allow you to handle all that within spinning up a new server.