MariaDB 10.4 install setup error

Debian 9 with MariaDB 10.4 (stable for a while now) After installing Virtualmin GPL and started post install configuration you get stopped by error: "SQL update user set authentication_string = password('[PASSWORD]') where user = 'root' and host = 'localhost' failed : Column 'authentication_string' is not updatable" while trying to set new MySQL password

Status: 
Fixed (pending)

Comments

Howdy -- thanks for your report!

On Debian 9, Virtualmin should use MySQL rather than MariaDB by default.

You're correct though that Virtualmin doesn't yet have support for MariaDB 10.3 and above. That's currently being worked on, as that also happens to be the default in Debian 10.

We expect to have support for that soon, and once we do, we'll announce Debian 10 support.

Status:
Active
»
Fixed (pending)

Will be implemented

This specific problem of setting the root password during install will be fixed in the next release.