Failed to lock file /var/webmin/modules/status/oldstatus

Hi,

I got regularly cron errors with:

Error: Failed to lock file /var/webmin/modules/status/oldstatus after 5 minutes. Last error was : Locked by PID 27010 Error
-----
Failed to lock file /var/webmin/modules/status/oldstatus after 5 minutes. Last error was : Locked by PID 27010
-----

Deleting the .lock files in /var/webmin/modules/status/ and restarting webmin don't help. ls -lA /var/webmin/modules/status/ shows:

-rw-r--r-- 1 root root 1.3K Oct  7 01:56 fails
-rw-r--r-- 1 root root    6 Oct  7 02:00 fails.lock
d-w-rwxr-T 2 root root 4.0K Oct  7 02:00 history
-rw-r--r-- 1 root root  291 Oct  7 01:56 lastsent
-rw-r--r-- 1 root root    6 Oct  7 02:00 lastsent.lock
-rw-r--r-- 1 root root  745 Oct  7 01:56 oldstatus
-rw-r--r-- 1 root root    6 Oct  7 02:00 oldstatus.lock

and ps aux |grep monitor.pl shows:

root     25832  0.0  0.0   4340   808 ?        Ss   09:20   0:00 /bin/sh -c /etc/webmin/status/monitor.pl
root     25836  0.1  0.1  41232 16684 ?        S    09:20   0:00 /usr/bin/perl /usr/share/webmin/status/monitor.pl
root     27005  0.0  0.0   4340   764 ?        Ss   02:00   0:00 /bin/sh -c /etc/webmin/status/monitor.pl
root     27010  0.0  0.2  81600 42128 ?        S    02:00   0:01 /usr/bin/perl /usr/share/webmin/status/monitor.pl

kill -9 27010 has no effect. Just deleting the .lock files and reboot the server helps to solve the issue(until the next weekend).

Status: 
Active

Comments

Seems like a status monitor has stalled on one of its checks, resulting in that lock never being released.

Did you add an any extra monitors to the defaults that virtualmin sets up?

Yes. I've attached a picture.