New installation error on centos 6 64Bit

Hello

cat virtualmin-install.log Checking for Perl...Loaded plugins: fastestmirror Setting up Install Process Loading mirror speeds from cached hostfile * base: mirror.alastyr.com * extras: mirror.radoreservers.com * updates: mirror.radoreservers.com Resolving Dependencies --> Running transaction check ---> Package perl.x86_64 4:5.10.1-144.el6 will be installed --> Processing Dependency: perl-libs = 4:5.10.1-144.el6 for package: 4:perl-5.10.1-144.el6.x86_64 --> Processing Dependency: perl-libs for package: 4:perl-5.10.1-144.el6.x86_64 --> Processing Dependency: perl(version) for package: 4:perl-5.10.1-144.el6.x86_64 --> Processing Dependency: perl(Pod::Simple) for package: 4:perl-5.10.1-144.el6.x86_64 --> Processing Dependency: perl(Module::Pluggable) for package: 4:perl-5.10.1-144.el6.x86_64 --> Processing Dependency: libperl.so()(64bit) for package: 4:perl-5.10.1-144.el6.x86_64 --> Running transaction check ---> Package perl-Module-Pluggable.x86_64 1:3.90-144.el6 will be installed ---> Package perl-Pod-Simple.x86_64 1:3.13-144.el6 will be installed --> Processing Dependency: perl(Pod::Escapes) >= 1.04 for package: 1:perl-Pod-Simple-3.13-144.el6.x86_64 ---> Package perl-libs.x86_64 4:5.10.1-144.el6 will be installed ---> Package perl-version.x86_64 3:0.77-144.el6 will be installed --> Running transaction check ---> Package perl-Pod-Escapes.x86_64 1:1.04-144.el6 will be installed --> Finished Dependency Resolution

Dependencies Resolved

================================================================================ Package Arch Version Repository

Size

Installing: perl x86_64 4:5.10.1-144.el6 base 10 M Installing for dependencies: perl-Module-Pluggable x86_64 1:3.90-144.el6 base 41 k perl-Pod-Escapes x86_64 1:1.04-144.el6 base 33 k perl-Pod-Simple x86_64 1:3.13-144.el6 base 213 k perl-libs x86_64 4:5.10.1-144.el6 base 579 k perl-version x86_64 3:0.77-144.el6 base 52 k

Transaction Summary

Install 6 Package(s)

Total download size: 11 M Installed size: 36 M

Downloading Packages:

Total 1.3 MB/s | 11 MB 00:08 Running rpm_check_debug Running Transaction Test Transaction Test Succeeded Running Transaction Installing : 1:perl-Pod-Escapes-1.04-144.el6.x86_64 1/6 Installing : 4:perl-libs-5.10.1-144.el6.x86_64 2/6 Installing : 1:perl-Module-Pluggable-3.90-144.el6.x86_64 3/6 Installing : 1:perl-Pod-Simple-3.13-144.el6.x86_64 4/6 Installing : 3:perl-version-0.77-144.el6.x86_64 5/6 Installing : 4:perl-5.10.1-144.el6.x86_64 6/6 Verifying : 3:perl-version-0.77-144.el6.x86_64 1/6 Verifying : 4:perl-libs-5.10.1-144.el6.x86_64 2/6 Verifying : 4:perl-5.10.1-144.el6.x86_64 3/6 Verifying : 1:perl-Module-Pluggable-3.90-144.el6.x86_64 4/6 Verifying : 1:perl-Pod-Simple-3.13-144.el6.x86_64 5/6 Verifying : 1:perl-Pod-Escapes-1.04-144.el6.x86_64 6/6

Installed: perl.x86_64 4:5.10.1-144.el6

Dependency Installed: perl-Module-Pluggable.x86_64 1:3.90-144.el6 perl-Pod-Escapes.x86_64 1:1.04-144.el6 perl-Pod-Simple.x86_64 1:3.13-144.el6 perl-libs.x86_64 4:5.10.1-144.el6 perl-version.x86_64 3:0.77-144.el6

Complete! found Perl at /usr/bin/perl Checking for HTTP client...found /usr/bin/wget -nv [2019-11-07 12:07:21 +0330] [DEBUG] Memory is greater than 1024 MB, which should be sufficient. [2019-11-07 12:07:21 +0330] [INFO] Started installation log in /root/virtualmin-install.log [2019-11-07 12:07:21 +0330] [DEBUG] Phase 1 of 3: Setup [2019-11-07 12:07:21 +0330] [DEBUG] Install mode: full [2019-11-07 12:07:21 +0330] [DEBUG] Product: Virtualmin GPL [2019-11-07 12:07:21 +0330] [DEBUG] install.sh version: 6.0.19 [2019-11-07 12:07:21 +0330] [DEBUG] Checking for fully qualified hostname... [2019-11-07 12:07:28 +0330] [ERROR] Your system hostname is not fully qualified. [2019-11-07 12:07:33 +0330] [DEBUG] Hostname OK: fully qualified as v.loval.loval [2019-11-07 12:07:33 +0330] [DEBUG] Primary address detected as 192.168.1.18 [2019-11-07 12:07:33 +0330] [DEBUG] Adding new entry for hostname v.loval.loval on 192.168.1.18 to /etc/hosts. [2019-11-07 12:07:33 +0330] [DEBUG] Installing serial number and license key into /etc/virtualmin-license [2019-11-07 12:07:33 +0330] [DEBUG] Operating system name: CentOS [2019-11-07 12:07:33 +0330] [DEBUG] Operating system version: 6.10 [2019-11-07 12:07:33 +0330] [DEBUG] Operating system type: centos [2019-11-07 12:07:33 +0330] [DEBUG] Operating system major: 6 [2019-11-07 12:07:33 +0330] [DEBUG] Configuring package manager for CentOS 6.10... [2019-11-07 12:07:33 +0330] [DEBUG] Disabling SELinux during installation... [2019-11-07 12:07:33 +0330] [DEBUG] setenforce 0 failed: 1 Spin pid is: 1551 2019-11-07 12:07:34 URL:https://software.virtualmin.com/vm/6/gpl/centos/6/x86_64/virtualmin-rele... [14112/14112] -> "virtualmin-release-latest.noarch.rpm" [1] Made it here...why? Downloading virtualmin-release-latest.noarch.rpm: Success. Spin pid is: 1593 warning: virtualmin-release-latest.noarch.rpm: Header V4 RSA/SHA1 Signature, key ID 60d62a6b: NOKEY Installing virtualmin-release package: Success. [2019-11-07 12:07:35 +0330] [DEBUG] Phase 2 of 3: Installation Spin pid is: 1635 2019-11-07 12:07:37 URL:https://dl.fedoraproject.org/pub/epel/epel-release-latest-6.noarch.rpm [14540/14540] -> "epel-release-latest-6.noarch.rpm" [1] Downloading epel-release-latest-6.noarch.rpm: Success. Spin pid is: 1708 warning: epel-release-latest-6.noarch.rpm: Header V3 RSA/SHA256 Signature, key ID 0608b895: NOKEY Installing EPEL release package: Success. Spin pid is: 1735 Loaded plugins: fastestmirror Setting up Install Process Loading mirror speeds from cached hostfile * base: mirror.alastyr.com * epel: mirror.serverion.com * extras: mirror.radoreservers.com * updates: mirror.radoreservers.com Resolving Dependencies --> Running transaction check ---> Package yum-utils.noarch 0:1.1.30-42.el6_10 will be installed --> Processing Dependency: libxml2-python for package: yum-utils-1.1.30-42.el6_10.noarch --> Running transaction check ---> Package libxml2-python.x86_64 0:2.7.6-21.el6_8.1 will be installed --> Finished Dependency Resolution

Dependencies Resolved

================================================================================

Package Arch Version Repository Size

Installing: yum-utils noarch 1.1.30-42.el6_10 updates 114 k Installing for dependencies: libxml2-python x86_64 2.7.6-21.el6_8.1 base 325 k

Transaction Summary

Install 2 Package(s)

Total download size: 439 k Installed size: 2.2 M

Downloading Packages:

Total 162 kB/s | 439 kB 00:02 Running rpm_check_debug Running Transaction Test Transaction Test Succeeded Running Transaction Warning: RPMDB altered outside of yum. Installing : libxml2-python-2.7.6-21.el6_8.1.x86_64 1/2 Installing : yum-utils-1.1.30-42.el6_10.noarch 2/2 Verifying : yum-utils-1.1.30-42.el6_10.noarch 1/2 Verifying : libxml2-python-2.7.6-21.el6_8.1.x86_64 2/2

Installed: yum-utils.noarch 0:1.1.30-42.el6_10

Dependency Installed: libxml2-python.x86_64 0:2.7.6-21.el6_8.1

Complete! Installing yum-utils: Success. Spin pid is: 2853 Enabling extras repository: Success. Spin pid is: 2884 Loaded plugins: fastestmirror Setting up Install Process Loading mirror speeds from cached hostfile * base: mirror.alastyr.com * epel: mirrors.coreix.net * extras: mirror.radoreservers.com * updates: mirror.radoreservers.com Resolving Dependencies --> Running transaction check ---> Package scl-utils.x86_64 0:20120927-29.el6_9 will be installed --> Finished Dependency Resolution

Dependencies Resolved

================================================================================

Package Arch Version Repository Size

Installing: scl-utils x86_64 20120927-29.el6_9 base 23 k

Transaction Summary

Install 1 Package(s)

Total download size: 23 k Installed size: 23 k Downloading Packages: Running rpm_check_debug Running Transaction Test Transaction Test Succeeded Running Transaction Installing : scl-utils-20120927-29.el6_9.x86_64 1/1 Verifying : scl-utils-20120927-29.el6_9.x86_64 1/1

Installed: scl-utils.x86_64 0:20120927-29.el6_9

Complete! Installing scl-utils: Success. Spin pid is: 3328 Loaded plugins: fastestmirror Setting up Install Process Loading mirror speeds from cached hostfile * base: mirror.alastyr.com * epel: ftp.plusline.net * extras: mirror.radoreservers.com * updates: mirror.radoreservers.com Resolving Dependencies --> Running transaction check ---> Package centos-release-scl.noarch 10:7-3.el6.centos will be installed --> Processing Dependency: centos-release-scl-rh for package: 10:centos-release-scl-7-3.el6.centos.noarch --> Running transaction check ---> Package centos-release-scl-rh.noarch 0:2-3.el6.centos will be installed --> Finished Dependency Resolution

Dependencies Resolved

================================================================================

Package Arch Version Repository Size

Installing: centos-release-scl noarch 10:7-3.el6.centos extras 12 k Installing for dependencies: centos-release-scl-rh noarch 2-3.el6.centos extras 12 k

Transaction Summary

Install 2 Package(s)

Total download size: 24 k Installed size: 39 k

Downloading Packages:

Total 19 kB/s | 24 kB 00:01 Running rpm_check_debug Running Transaction Test Transaction Test Succeeded Running Transaction Installing : centos-release-scl-rh-2-3.el6.centos.noarch 1/2 Installing : 10:centos-release-scl-7-3.el6.centos.noarch 2/2 Verifying : centos-release-scl-rh-2-3.el6.centos.noarch 1/2 Verifying : 10:centos-release-scl-7-3.el6.centos.noarch 2/2

Installed: centos-release-scl.noarch 10:7-3.el6.centos

Dependency Installed: centos-release-scl-rh.noarch 0:2-3.el6.centos

Complete! Install Software Collections release package: Success. Spin pid is: 3888 Warning: Group scl-php72 does not have any packages. Installing PHP7: Success. Spin pid is: 4430 Package iptables-1.4.7-19.el6.x86_64 already installed and latest version Package python-2.6.6-66.el6_8.x86_64 already installed and latest version Package openssl-1.0.1e-57.el6.x86_64 already installed and latest version Package logrotate-3.7.8-28.el6.x86_64 already installed and latest version Package cyrus-sasl-2.1.23-15.el6_6.2.x86_64 already installed and latest version Package bzip2-1.0.5-7.el6_0.x86_64 already installed and latest version Package ca-certificates-2018.2.22-65.1.el6.noarch already installed and latest version http://mirror.radoreservers.com/centos/6.10/extras/x86_64/repodata/11787... [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found" Trying other mirror. To address this issue please refer to the below wiki article

https://wiki.centos.org/yum-errors

If above article doesn't help to resolve this issue please use https://bugs.centos.org/.

http://mirror.rackdc.com/CentOS/6.10/extras/x86_64/repodata/117872a04739... [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found" Trying other mirror. http://ftp.linux.org.tr/centos/6.10/extras/x86_64/repodata/117872a04739d... [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found" Trying other mirror. http://mirror.centos.jt.iq/6.10/extras/x86_64/repodata/117872a04739d600b... [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found" Trying other mirror. http://mirror.scopesky.iq/6.10/extras/x86_64/repodata/117872a04739d600b3... [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found" Trying other mirror. http://repo.inara.pk/centos/6.10/extras/x86_64/repodata/117872a04739d600... [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found" Trying other mirror. http://ftp.itu.edu.tr/Mirror/CentOS/6.10/extras/x86_64/repodata/117872a0... [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found" Trying other mirror. http://mirrors.ges.net.pk/centos/6.10/extras/x86_64/repodata/117872a0473... [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found" Trying other mirror. http://mirror.earthlink.iq/centos/6.10/extras/x86_64/repodata/117872a047... [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found" Trying other mirror. http://centos.mirror.infinity.iq/6.10/extras/x86_64/repodata/117872a0473... [Errno 12] Timeout on http://centos.mirror.infinity.iq/6.10/extras/x86_64/repodata/117872a0473... (28, 'connect() timed out!') Trying other mirror. Error: failure: repodata/117872a04739d600b36438d763d7809ce825e58a2094f7a531edae39c7dc1bcb-filelists.sqlite.bz2 from extras: [Errno 256] No more mirrors to try. Installing dependencies and system packages: [2019-11-07 12:10:11 +0330] [ERROR] Failed with error: 1 [2019-11-07 12:10:11 +0330] [ERROR] Something went wrong. Exiting. [2019-11-07 12:10:11 +0330] [ERROR] The last few log entries were:

Status: 
Closed (fixed)

Comments

Assigned: ยป Unassigned

Howdy -- thanks for your report!

That's an unusual error, and we'll review what might be causing that, though it may be an issue with the CentOS 6 mirrors... I'm not immediately seeing a Virtualmin problem in the above.

That said, if at all possible we'd definitely recommend a newer distro than CentOS 6 -- it will be reaching it's end of life next year, meaning CentOS and Virtualmin will no longer be supporting it and offering updates.

Yes I know centos 6 will reach to EOL next year but i need this for one of my projects

Also tried three different repos and resault is same

Could you attach the /root/virtualmin-install.log file to this request? That would help us look into that. Thanks!

Status:
Active
»
Closed (fixed)

Hello,

Look like repos blacklisted server IP

Changed server IP and now virtualmin installed