Server crashes after I installed virtualmin

8 posts / 0 new
Last post
#1 Thu, 11/28/2019 - 04:11
support@flconsult.dk

Server crashes after I installed virtualmin

I running Virtualmin on a 64bit ubuntu 18.04 server in VMware and I can kill the server using wget after I installed Virtualmin

$ wget https://downloads.joomla.org/da/cms/joomla3/3-9-13/Joomla_3-9-13-Stable-...

Will crash the system and I don't know why, it drops all network connects and I can't access the server using the VMware console, I have to reset the server to return it to an operational state.

I guessing the problem is DNS related, how do it debug or fix this problem?

$ wget https://downloads.joomla.org/da/cms/joomla3/3-9-13/Joomla_3-9-13-Stable-... --2019-11-28 10:08:40-- https://downloads.joomla.org/da/cms/joomla3/3-9-13/Joomla_3-9-13-Stable-... Resolving downloads.joomla.org (downloads.joomla.org)... 72.29.124.146 Connecting to downloads.joomla.org (downloads.joomla.org)|72.29.124.146|:443... connected. HTTP request sent, awaiting response... 303 See Other Location: https://s3-us-west-2.amazonaws.com/joomla-official-downloads/joomladownl... [following] --2019-11-28 10:08:41-- https://s3-us-west-2.amazonaws.com/joomla-official-downloads/joomladownl... Resolving s3-us-west-2.amazonaws.com (s3-us-west-2.amazonaws.com)... 52.218.160.60 Connecting to s3-us-west-2.amazonaws.com (s3-us-west-2.amazonaws.com)|52.218.160.60|:443... connected.

This is how I can reproduce the crash.

Thu, 11/28/2019 - 05:01
unborn
unborn's picture

@support@flconsult.dk

hi, 18.xx is well outdated - try to use latest version of your os (as you said ubuntu) - it will work.. :)

  • regards your joomla issues - I would consider better and secured cms.. perhaps speak to people from joomla on their own forums.. this is about virtualmin not web dev support... ya know I am sorry..

have good day.

Configuring/troubleshooting Debian servers is always great fun

Contact me directly ? GPG/PGP supported!

Thu, 11/28/2019 - 05:29 (Reply to #2)
support@flconsult.dk

How is it well outdated? 18.04.3 is the current LTS version and will remain supported until april 2023, are you trying to tell me that I can't use the LTS (Long Term Support)?

The problem is not related to joola, using wget to download joomla just triggers the crash.

The problem has to do with wget, the server will use wget for other automated tasks which crash the server after I have installed Virtualmin.

Thu, 11/28/2019 - 06:09
unborn
unborn's picture

its well outdated.. regards the the mind - please consider this one thing.. you are not using it as an desktop or laptop - you are using it as an server - which is different however here you go: https://ubuntu.com/about/release-cycle - which does not say much.. however : https://wiki.ubuntu.com/BionicBeaver/ReleaseNotes

Now as you correctly noted I use debian which should mean I would be 4 or more years behind ubuntu, well non of this is true.. debian changed its development and so ubuntu long time back ago. ubuntu is may based on debian but to due its modifications to its own os derivations and changes - its more less incompatibile (you have to read ubuntu forums which are great) or change the system. In symple words.. Ive installed debian 6 on my system years ago and then setup virtualmin.. right after, during those years all I used was apt-get update && upgrate, while I upgrade disrto it self from 6 to 10.. with another single command.. - it still does work - all Ive changed was physical - to put 1 gig more ram to my server and another 10 tb hdd.. nothing else.. thats how different ubuntu is for me.. its not possible with that os for me.. also I am debian user on my laptops and desktops full time , please note it that I came from ubuntu as newcomer to linux.. while back it was.. I think it was ubuntu 6 if I remember correctly..

problem seems to be wget you said? wget is very simple program and it works via gui and terminal - its just stupid, you tell the program to do some stuff and it will give you its life.. I do not think the problem si the program you use.. sorry to say that, perhaps the problem is between the chair and keyboard on your side or perhaps you do not know how to use wget - which is the same problem or perhaps ubuntu did changed something again.. which would not surprised me at all..

your original post was problem with joomla but now its wget - which is very solid and very simple but powerful program.. so are you sure you do issued your command as user need it to download joomla? what command you did issued? ram of your server and cpu? I guess hdd is more then 100gb..

if you have issues with wget and cron.... then your command must not meet your system or/nor you issued correctly..

let us know.

Configuring/troubleshooting Debian servers is always great fun

Contact me directly ? GPG/PGP supported!

Thu, 11/28/2019 - 07:14
unborn
unborn's picture
  • no one will understand the answer to its own question if he do not know what he is asking.... that's where the mistakes only happens :)

Configuring/troubleshooting Debian servers is always great fun

Contact me directly ? GPG/PGP supported!

Sun, 12/01/2019 - 01:15
quakebox

Ubuntu 18.04 LTS "Long Term Support" outdated? I don't think so.

Maybe the Original Poster can give more information about his setup first is he using a new hardware or old exhausted machine there are tons of causes that cause errors and malfunction the key to solve a problem is troubleshooting by eliminating one cause at a time.

OP, according to you wget program crashes your server? This is very weird issue.

Mon, 12/02/2019 - 14:54
scotwnw

I have not had a good laugh in a while. 18.04 outdated! LOLLLLLLLLL.

FYI, 18.04 means was released 2018 and 4th month. The 4th month is always when new LTS releases are generally done and LTS is only on even years. The odd years, like 19.04, is only supported one year and is mainly for testing purposes of new code. Things like 19.10 mean 2019 and 10th month of updates. So 18.04 is the latest that should be user for public server.

AS far as the orig question, wget merely downloads. Unless memory or disk space are low, I dont see how wget can lock it up. Unless it just sitting waiting on a reply and it just looks like it locked?

Tue, 12/03/2019 - 14:44
adamjedgar

I am running and old joomla 2.5 website that was updated to joomla 3 however it has gantry v4 framework used for website...which only runs on php 5.6.

I have absolutely no problems running this cms on a debian 9 vps on Vultr (which I think uses KVM?) The system is 2cpu 4gb ram. It has WordPress websites on it as well. I have all php pm set to on-demand(instead of dynamic) in php-fpm config filles for each virtusl server, and I use "Event" instead of the default "Prefortk"...this is to to keep ram usage down.

I think it's bumkim that joomla has anything to do with this. To be honest, between joomla and WordPress I'm certain joomla runs websites faster.

Unlike WordPress, Joomla was designed as a full blooded CMS from the outset. WordPress is not a genuine CMS, it's a blogging platform that became a CMS via the addition of third party plugins. Fundamentally Joomla will always be the better cms of the two because of that, and I believe always more efficient too.

The only problem with joomla is it's very very mechanical to develop with. Far too much clicking buttons here, clicking buttons there to get even the most basic tasks done...that's the only problem with it.

Your problem definitely is not joomla on Ubuntu 18.

I think more likely that virtualmin is not running properly on Ubuntu 18 yet. Go back to Ubuntu 16 and see if you have the same issue? I would suggest taking your problem to "ask ubuntu". Get the guys who know Ubuntu to help you.

AJECreative is the home of $5 webhosting, $15/month VPS servers (1cpu,1gb RAM, 25GB storage)
Centos7, Debian9, or Ubuntu18LTS
Available Control Panels = Centos-Webpanel, Cyberpanel, or Virtualmin

https://ajecreative.com.au