Update Virtualmin impossible due to shared-mime-info

6 posts / 0 new
Last post
#1 Thu, 11/28/2019 - 10:56
Robert54

Update Virtualmin impossible due to shared-mime-info

Hello,

Operating system Debian Linux 7.7 Webmin version 1.921 Usermin version 1.771 Virtualmin version 6.08

When I try to update webmin and usermin I have this:

Reading package lists... Building dependency tree... Reading state information... The following extra packages will be installed: shared-mime-info The following NEW packages will be installed: shared-mime-info The following packages will be upgraded: usermin webmin 2 upgraded, 1 newly installed, 0 to remove and 0 not upgraded. Need to get 26.3 MB of archives. After this operation, 3576 kB of additional disk space will be used. WARNING: The following packages cannot be authenticated! shared-mime-info E: There are problems and -y was used without --force-yes

I am concerned because og this : Webmin versions below 1.930 contain a remotely exploitable security hole and should be upgraded immediately

What can I do?

Best regards Robert54

Thu, 11/28/2019 - 12:50
Jfro

https://duckduckgo.com/?q=Debian+Linux+7.7+shared-mime-info+E&t=hr&ia=web

Did you start here before installing and update? https://www.virtualmin.com/os-support.html i think this is also for webmin and usermin

Debian 8 and 9 on i386 and amd64

Mon, 12/02/2019 - 03:11
Robert54

Hello,

for various and numerous reasons I can't update the OS. I just want to kow if it is possible to force the shared-mime-info on a debian 7.7 and if it is safe.

Best regards Robert54

Mon, 12/02/2019 - 09:03
Jfro

Sorry don't know .

But better be prepared for next upcommming webmin virtualmin update , expect again some bigger changes while debian 10....

Mon, 12/09/2019 - 05:11
Robert54

Hello,

I haven't found another topic in this forum with the same problem. Maybe I am the only one. Here (http://www.webmin.com/security.html) there is an alternative:

"...if running versions 1.900 to 1.920, edit /etc/webmin/miniserv.conf, remove the passwd_mode= line, then run /etc/webmin/restart."

But first my webmin version is 1.921, and Ichecked the passwd_mode= has always been 0.

Maybe I am safe for now.

Regards Robert54

Mon, 12/09/2019 - 13:55
partaload

Hello. Robert, I'm in the same situation. I cannot upgrade my Wheezy and my Webmin version is 1.921 which I cannot upgrade either because of the uninstalled and uninstallable "shared-mime-info" .

Did you manage to solve it?

Regards