Missing Perl libraries on Ubuntu 18.04.3 / Virtualmin GPL 6.08 on DigitalOcean

Just wanted to mention that Virtualmin backups wouldn’t work until I installed libxml-simple-perl and libdigest-hmac-perl. (I was getting errors like, “The Perl module Digest::HMAC_SHA1 needed to communicate with Amazon's S3 service is not installed”.)

apt install libxml-simple-perl
apt install libdigest-hmac-perl

I also tried installing libwww-perl, and it seemed to be installed already.

apt install libwww-perl
Status: 
Active

Comments

Ilia's picture
Submitted by Ilia on Fri, 02/14/2020 - 03:38

Status:
Active
»
Closed (works as designed)

Hi,

Thanks for your feedback. Even though, you are right, it's recommended to use native command for managing your Amazon S3 Bucket.

You can install it on your Ubuntu 18 using the following command:

apt install awscli
Status:
Closed (works as designed)
»
Active

No, I don’t think you understand. The error I got was when using the “Backup and Restore” command in the Virtualmin web UI. This is a bug.

Expected behavior: No error. Attempted backup would continue. Virtualmin would presumably install these libraries during /install.sh or on-the-fly when running the Backup and Restore command.

ps. If awscli is recommended, perhaps include that in the Backup and Restore warnings?

Ilia's picture
Submitted by Ilia on Fri, 02/14/2020 - 16:44

Assigned: Unassigned »

Okay, good point. I will pass this to Joe for a comment and a fix.

Thanks for your feedback. Appreciate!