Setting a password with special characters (SSH / New Owner Password) and creating shows a "Missing Password" Error

Hi there,

We tried to create a Cloudmin KVM VPS instance today and when we set a character with about 20 characters with special characters as the new owner password / SSH password and clicked "Create", Cloudmin responded that the password was missing. Please let us know if you guys can replicate this issue. Thank you!

Here is an example of a password that was used: ;Q<.)Sr@M8K>>_M'4B

The password character limits should definently be defined in the panel when inputting any password so the user knows the limits. Thank you.

Status: 
Active

Comments

That's odd - there are no limits on the password length in Cloudmin. Can you post the exact error message here?

Ilia's picture
Submitted by Ilia on Fri, 03/20/2020 - 05:00

Additionally to what Jamie asked, does it work if you're not using HTML entries, like < or > in your password? I'm thinking that maybe we extra-escaping something which shouldn't be escaped?

thedaemexco's picture
Submitted by thedaemexco on Fri, 03/20/2020 - 10:19 Pro Licensee

Hi there, thank you for the response! Well, we just tried again and used the password above and it worked just fine. If it happens again, we'll let you guys know. We are currently in the process of writing our own WHMCS module for Cloudmin because the default one just doesn't work at all. Just wanted to make sure that there weren't any restrictions to the passwords so we can pass this information on to the developers. You can close this issue for now and if it happens again, we'll give you more details on exactly how to reproduce it. We lost the password that was used that caused the error, unfortunatley.