Install PHP 7.4 or 7.3 on CentOS 8.2

Drupal 9.0 requires PHP 7.3+ How can PHP 7.4 be installed to be used with virtualservers on CentOS 8.2 that comes with PHP 7.2?

Server and database requirements

Drupal 9 requires PHP 7.3 or higher, and the version requirement for Apache has been increased to Apache 2.4.7 or higher. The following database versions are supported by Drupal 9 core:

MySQL or Percona 5.7.8.
MariaDB 10.3.7 (Note that this is a more recent release than the MySQL version.)
PostgreSQL 10 with the pg_trgm extension.
SQLite 3.26 (PHP does not always use the system-provided SQLite, so verify that your PHP is compiled with at least this version).
Status: 
Active
Virtualmin version: 
6.12
Webmin version: 
1.955

Comments

Ilia's picture
Submitted by Ilia on Mon, 09/14/2020 - 14:17

Hi,

I have updated our docs to include instructions on how to install PHP 7.3 and 7.4 on CentOS 8.

pixel_paul's picture
Submitted by pixel_paul on Mon, 09/21/2020 - 10:02 Pro Licensee

If you do not want to use the Remi repo you can upgrade PHP to 7.3 using the AppStream version:

dnf install epel-release dnf module list php dnf module reset php dnf module enable php:7.3 dnf update

On some servers I found I needed to remove php first, then do an install.

PHP 7.4 will be released through this channel soon too.