Backup Directory Error

1 post / 0 new
#1 Thu, 01/17/2008 - 06:02
mhosts

Backup Directory Error

Hey guys, I'm having a problem with virtualmin pro in terms of backups... I've set my backup directory to be /backup/ns1/%B%Y/%d... /backup is an nfs filesystem to another server (which shouldn't really matter because the permissions are correct).

It seems like the script isn't creating the directories but rather assuming they will already be there, This happens both when I click and Un-Click "Create destination directory?" Option

This is the output I'm getting from virtualmin:

Starting backup of 30 domains to local file /backup/ns1/January2008/17 ..

Creating backup for virtual server foo.com ..

Copying virtual server configuration .. .. done Backing up Cron jobs .. .. none defined. Saving mail aliases .. .. done Saving mail and FTP users .. .. done Backing up mail and FTP user Cron jobs .. .. none to backup Copying records in DNS domain .. .. done Copying Apache virtual host configuration .. .. done Copying Webalizer configuration files .. .. done Copying Logrotate configuration .. .. done Copying Procmail and SpamAssassin configuration files .. .. done Backing up Webmin ACL files .. .. done Backing up AWstats configuration file .. .. done Creating TAR file of home directory .. .. TAR failed! sh: /backup/ns1/January2008/17/foo.com.tar.gz: No such file or directory Backing up Virtualmin settings (Module configuration, Server templates, Reseller accounts, New mailbox email messages, Custom fields, Third-party script installers, Third-party content styles) .. .. done Backup failed! See the progress output above for the reason why.