Invalid wiki admin password: Passwords must be at least 10 characters.

Install script for Mediawiki on freshly created virtualhost name, selecting the install option:

Initial login for script   
Same username and password as domain

Results in a failed install with error messages:

Found http://releases.wikimedia.org:80/mediawiki/1.35/mediawiki-1.35.0.tar.gz in cache ..

Configuring webserver PHP settings ..
.. already done.
Applying web server configuration ..
.. done
Now installing MediaWiki version 1.35.0 ..
Installation script failed :
Invalid wiki admin password: Passwords must be at least 10 characters.
More information on using this script can be found at http://www.mediawiki.org/.

.. installation was only partially complete.
Re-loading Webmin ..
.. done
Applying web server configuration ..
.. done

Upon investigation, I discovered the script was installed, contrary to the message indicating install failure.

The username for the domain had been installed with a pre-encrypted password which I thought exceeded 10 characters. But to make sure I uninstalled Mediawiki, went into user/groups to change its password to one >10 characters, went back to the install scripts and reinstalled Mediawiki only to receive the same errors.

Status: 
Fixed (pending)
Virtualmin version: 
6.13
Webmin version: 
1.960

Comments

I was able to get the MediaWiki up and running by going through their configuration wizard, downloading the LocalSettings.php and then uploading it to the wiki's index.php directory.

Ilia's picture
Submitted by Ilia on Mon, 11/16/2020 - 16:44

Status:
Active
»
Fixed (pending)

Good point, thanks. We will add password requirements for script library.