Webmail and Admin Redirects always on for Sub-Domain

Hey guys! Basically all my sub-domains are gettings webmail and admin records being created, even if I disable them in the server template.

I went to: Virtualmin > System Settings > Server Templates > Settings for Sub-Servers > Website for domain

And disabled both functions below and I still get admin.sub-domain.domain.tld and webmail.sub-domain.domain.tld records in DNS settings for that sub-domain.

Redirect webmail.${DOM}? Redirect admin.${DOM}?

I'm using sub-domain because I use CloudFlare as a DNS/CDN for all domains I host. Since creating a sub-server I will face issues with SSL, I rather use sub-domain to avoid that.

Besides that, is there any ETA for CloudFlare integration with Virtualmin? I always use Virtualmin BIND DNS records to import in CloudFlare. So if any domain needs a new sub-domain I need to manually export the dns to Cloudflare :(

Thanks!

Status: 
Fixed (pending)
Virtualmin version: 
6.13
Webmin version: 
1.962

Comments

Title: Webmail and Admin Redirects always on for Sub-server ยป Webmail and Admin Redirects always on for Sub-Domain

Note that disabling this in the template will only effect new domains created using that template - existing domains won't be updated.

I know, but I disabled it and then deleted the domain and recreated it, the new domain keeps getting this admin/webmail redirects even though those functions are disabled.

Does this happen only for sub-domains, or also for top-level domains?

Top-level domains work as expected. If redirects are disabled in Server Templates > Default Settings, DNS entries are not created. But it doesn't work for Sub-server and sub-domain when redirects are disabled in Server Templates > Settings For Sub-Servers

Status:
Active
»
Fixed (pending)

Thanks - I found the bug, and will fix this in the next release.

Glad to help :D