nginx do not automatically start after reboot but works after manual start

nginx do not automatically start after reboot and the error message i get is

2020/12/11 22:04:35 [emerg] 651#651: bind() to [2a01:7e01::f03c:92ff:fedc:e4ed]:80 failed (99: Cannot assign requested address)

after manual start it works without error

I checked and there is no apache service booting

also i noticed that for few minutes the nginx service in dashboard has a green V (checked)

after

service nginx status

i have this message

‚óŹ nginx.service - A high performance web server and a reverse proxy server
     Loaded: loaded (/lib/systemd/system/nginx.service; enabled; vendor preset: enabled)
     Active: failed (Result: exit-code) since Sat 2020-12-12 10:55:53 EET; 3min 11s ago
       Docs: man:nginx(8)
    Process: 648 ExecStartPre=/usr/sbin/nginx -t -q -g daemon on; master_process on; (code=exited, status=1/FAILURE)

Dec 12 10:55:53 com.com.gr systemd[1]: Starting A high performance web server and a reverse proxy server...
Dec 12 10:55:53 com.com.gr nginx[648]: nginx: [emerg] bind() to [2a01:7e01::f03c:92ff:fedc:e5ed]:80 failed (99: Cannot assign requested address)
Dec 12 10:55:53 com.com.gr nginx[648]: nginx: configuration file /etc/nginx/nginx.conf test failed
Dec 12 10:55:53 com.com.gr systemd[1]: nginx.service: Control process exited, code=exited, status=1/FAILURE
Dec 12 10:55:53 com.com.gr systemd[1]: nginx.service: Failed with result 'exit-code'.
Dec 12 10:55:53 com.com.gr systemd[1]: Failed to start A high performance web server and a reverse proxy server.

com.com.gr is not my real domain

Status: 
Active
Virtualmin version: 
6.14
Webmin version: 
1.962

Comments

Do you perhaps also have Apache configured to start at boot time? You can check for this at Webmin -> System -> Bootup and Shutdown.