Webmin can not resolve apt

Hi I keep getting nagged about a software update when you run system->Software Package Updates there are no updates showing to update. However when you click refresh packages webmin returns "1 possible update" .. clicking return to updates shows no packages to update. so I went to apt and did apt update

Building dependency tree       
Reading state information... Done
1 package can be upgraded. Run 'apt list --upgradable' to see it.

now ran apt list --upgradable

Listing... Done
lazygit/focal 0.26.1-1~ubuntu20.04.1 amd64 [upgradable from: 0.26-1~ubuntu20.04.1]
N: There is 1 additional version. Please use the '-a' switch to see it
root@vps99696888:/home/tracey# apt list --upgradable -a
Listing... Done

I am guessing Webmin doesn't like the additional version & only expects one , by adding the -a switch you get, in this instance,

Listing... Done
lazygit/focal 0.26.1-1~ubuntu20.04.1 amd64 [upgradable from: 0.26-1~ubuntu20.04.1]
lazygit/now 0.26-1~ubuntu20.04.1 amd64 [installed,upgradable to: 0.26.1-1~ubuntu20.04.1]

perhaps webmin should just choose the one that is installed ? To date I have not installed just in case you wanted to log in and take a look. btw any new on this issue yet ?

Status: 
Active
Virtualmin version: 
615
Webmin version: 
1972

Comments

Do you have the apt-show-versions command installed on your system? If so, what output do you get if you run apt-show-versions | grep lazygit

jimr's picture
Submitted by jimr on Mon, 03/15/2021 - 01:34 Pro Licensee

lazygit:amd64/focal 0.26-1~ubuntu20.04.1 upgradeable to 0.26.1-1~ubuntu20.04.1