Wide character in syswrite and IDN domains

8 posts / 0 new
Last post
#1 Thu, 05/29/2008 - 01:33
kkk

Wide character in syswrite and IDN domains

Hello,

I recently moved to a new server and I started getting the following error when I try to enter the punycode version of an IDN domain(s, HTTP/1.0 500 Perl execution failed Server: MiniServ/0.01 Date: Thu, 29 May 2008 10:19:39 GMT Content-type: text/html Connection: close Error - Perl execution failed Wide character in syswrite at /usr/libexec/webmin/miniserv.pl line 2630.

Before moving to the new server I didn't had any kind of problems with that.

new server: CentOS virtualmin version: 1.420 perl: This is perl, v5.8.8 built for i386-linux-thread-multi

old server: Debian 4.0 old virtualmin version: 1.410 old perl: v5.8.8 built for i486-linux-gnu-thread-multi

The regular ASCII domains work without problem. here is what punycode is http://en.wikipedia.org/wiki/Punycode maybe it has something to do with virtualmin or perl thinking that the punycode string needs translation? weird.

Thu, 05/29/2008 - 21:08
kkk

how do I delete added servers in virtualmin without using the web interface? I was able to add one IDN domain (punycode) after renaming an already added ASCII domain but now virtualmin crashes when it tries to display the list of domains when it gets to displaying the punycode domain..

Fri, 05/30/2008 - 06:26 (Reply to #2)
Joe
Joe's picture

<div class='quote'>but now virtualmin crashes when it tries to display the list of domains when it gets to displaying the punycode domain..</div>

That would be a bug. I imagine the bug tracker would be a good option for getting it fixed (assuming you're running the latest Virtualmin version--you've only told us the Webmin version).

As for deleting domains from the command line, there is a delete-domain.pl script in the virtual-server directory.

It actually sounds like Webmin's web server isn't handling non-8-bit characters. But, again, you'll want to file a bug so it can get fixed.

--

Check out the forum guidelines!

Sun, 06/01/2008 - 02:41 (Reply to #3)
kkk

thank you.

sorry I forgot the virtualmin versions:

3.54.gpl - works
3.572.gpl - doesn't work

I'll file a bug, thank you again.

Sun, 06/07/2009 - 07:23
kkk

I submitted a bug report but it got deleted, I have no idea why.

I found the real problem. It seems that IDN support has been introduced in virtualmin but it doesn't work as it should yet. I can add domains in other languages but virtualmin's punycode ends up being wrong. for example:

IDN domain (cyrillic): &ETH;&acute;&Ntilde;

Sun, 06/07/2009 - 07:23
kkk

I submitted a bug report but it got deleted, I have no idea why.

I found the real problem. It seems that IDN support has been introduced in virtualmin but it doesn't work as it should yet. I can add domains in other languages but virtualmin's punycode ends up being wrong. for example:

IDN domain (cyrillic): &ETH;&acute;&Ntilde;

Sun, 06/01/2008 - 20:38
Joe
Joe's picture

<div class='quote'>I submitted a bug report but it got deleted, I have no idea why.</div>

No bug report at Virtualmin.com is <i>ever</i> deleted. Your bug was commented on, Jamie committed a fix to Subversion, and the problem will be fixed in version 3.58 of Virtualmin. The bug was then closed, because the problem is fixed by an upcoming release.

Jamie's just so fast that if you aren't paying attention, your bug will disappear before you know it. ;-)

--

Check out the forum guidelines!

Sun, 06/01/2008 - 22:30
kkk

you guys rock <img src='http://img150.imageshack.us/img150/4207/thumbsupym2.gif' style='border:0px'>