broken packages in etch after debian 5.0 release?

19 posts / 0 new
Last post
#1 Sun, 02/15/2009 - 02:40
mom

broken packages in etch after debian 5.0 release?

does anybody try to setup a fresh etch-system since yesterday(release-day of lenny as stable)? installing php5 and clamav result in "broken packages" because higher versions of libc6 are required for example... running the virtualmin install.sh script fails too. what can i do?

thank you for any help!

mom

Sun, 02/15/2009 - 04:56
Hal9000

i setup a fresh debian 4.0 + virtualmin system in a vmware machine to simulat an upgrade to etch, but i already got problems on the aptitude dist-upgrade command, citing problems with broken packages and others with unmet dependencies.
so i guess virtualmin is not compatible with lenny yet, we'll have to wait until virtualmin releases a new version...

Sun, 02/15/2009 - 04:57 (Reply to #2)
Hal9000

btw, tomorrow i will read this: http://debian.org/releases/lenny/amd64/release-notes/ch-upgrading.en.html and see if an upgrade is possible with that path :)

Sun, 02/15/2009 - 06:06 (Reply to #3)
mom

hi Hal9000,

thank you for your repro!
this is really not a problem of virtualmin, but of the incorrect set dependencies of the php5-package who points to libc6 >=2.7-1. the stable etch-version contains ver. 2.3.6.
an upgrade to lenny is not the solution because the install-script of virtualmin isn't running on it...
supported are debian 3+4.
yesterday i purchased a pro-license and now i'm not able to use it:-(

regards,
mom

Sun, 02/15/2009 - 06:12 (Reply to #4)
andreychek

Yeah, Joe mentioned that Debian 5 support will be available in the near future.

Debian 4, however, should continue to work fine.

If the install.sh fails, you should open a support ticket using the Bugs and Issues link below.

Take the resulting /root/virtualmin-install.log, and any other errors you see, and attach those to the request.
-Eric

Sun, 02/15/2009 - 10:57 (Reply to #5)
Joe
Joe's picture

Yes, now that 5.0 has arrived, I will have Virtualmin working on it within a few days. Since our Apache package isn't available for 5.0 yet, you'll definitely want to wait until that happens.

--

Check out the forum guidelines!

Mon, 02/16/2009 - 05:53 (Reply to #6)
mom

yesterday i was looking the whole day at several forums for an answer to my problem with the broken packages in my etch-setup, but i didn't find one.
i'm not sure if i made a mistake during setup. but no error occured and the system is running fine. if there wasn't the problem with php5 and clamav.

steps on dom0 (sources.list points to etch, not to stable):

[code:1]dom0:~#xen-create-image --my.fq.dn --size=100Gb --swap=512Mb --ide --ip=xx.xx.xx.xxx --netmask=xxx.xxx.xxx.xxx --gatewy=xx.xx.xx.xxx --force --dir=/home/xen/ --memory=1024Mb --debootstrap --dist=etch --mirror=http://ftp2.de.debian.org/debian/ --passwd[/code:1]

steps on domU1:

[code:1]my:~#apt-get update
my:~#apt-get upgrade
my:~#aptitude install php5-common[/code:1]

-->unmet dependencies, because php5-common depends on libc6 =>2.7-1
libc6 2.3.6 is the version of the old stable etch...

Mon, 02/16/2009 - 05:59 (Reply to #7)
mom

my god, what a problem is it with displaying the code???
is this a bug in ff3?
my preview also is shown in white letters...

Mon, 02/16/2009 - 06:04 (Reply to #8)
mom

hi HAL9000,

no backports in sources.list.
i think i have to setup a new xen dom0 to solve it.
but, before the release of deb5 all was fine with new setups like this way.

here my reply without inserting code...

yesterday i was looking the whole day at several forums for an answer to my problem with the broken packages in my etch-setup, but i didn't find one.
i'm not sure if i made a mistake during setup. but no error occured and the system is running fine. if there wasn't the problem with php5 and clamav.

steps on dom0 (sources.list points to etch, not to stable):

dom0:~#xen-create-image --my.fq.dn --size=100Gb --swap=512Mb --ide --ip=xx.xx.xx.xxx --netmask=xxx.xxx.xxx.xxx --gatewy=xx.xx.xx.xxx --force --dir=/home/xen/ --memory=1024Mb --debootstrap --dist=etch --mirror=http://ftp2.de.debian.org/debian/ --passwd

steps on domU1:

my:~#apt-get update
my:~#apt-get upgrade
my:~#aptitude install php5-common

-->unmet dependencies, because php5-common depends on libc6 =>2.7-1
libc6 2.3.6 is the version of the old stable etch...

Mon, 02/16/2009 - 06:33 (Reply to #9)
andreychek

Just for fun, could you post your /etc/apt/sources.list?

Also, are there any additional repositories setup in /etc/apt/sources.list.d/ ?
-Eric

Mon, 02/16/2009 - 07:11 (Reply to #10)
mom

Eric, thank you very much for THAT posting!
i found the mistake, in deed in the sources list(how embarrassing!).
the package-mirror really pointed to etch, but the security-mirror pointed to stable.
corrected to etch and now it works:-)), also virtualmin-setup is done.

thanks to all of you!!!
regards,
Kai

Mon, 02/16/2009 - 10:19 (Reply to #11)
Joe
Joe's picture

<div class='quote'>my god, what a problem is it with displaying the code???
is this a bug in ff3?
my preview also is shown in white letters...</div>

This forum is horrible. It will be gone soon.

--

Check out the forum guidelines!

Sun, 02/15/2009 - 12:15
Hal9000

ok i followed the release note instructions to upgrade, so i did the following:

- updated /etc/apt/sources.list to get lenny stuff (except virtualmin)
- apt-get update
- apt-get install apt
- aptitude install aptitude
- aptitude upgrade

everything perfectly fine until here, but now

- aptitude dist-upgrade
basically it says that libsasl2 and virtualmin-base are BROKEN packages cause of unmet dependencies:
libsasl2 depends on an older version... but i guess reinstalling that later on would fix that.
then it says virtualmin-base depends on proftpd-common which is a virtual package.

also, as joe warned, the virtualmin apache package got replaced with the debian apache2 package, which i guess is not a good thing :P

i guess i will attempt another upgrade attempt once virtualmin will actually have lenny packages :)

Mon, 02/16/2009 - 05:58
Hal9000

are you using some sort of php5 backport?
no problems here in upgrading the php5 packages, i'm using the debian ones.

Mon, 02/16/2009 - 14:18
denisius.sion

I'm going to install debian 5 in one week on our dedicated server, but without support of webmin installation script it is useless. I understand that it's so hard to answer exactly, but when I can use installation script for webmin without any script? I really want to know at least approximately date. Thanks a lot for answer!

Mon, 02/16/2009 - 14:20 (Reply to #15)
denisius.sion

&quot;script for webmin without any script?&quot;
Sorry I mean: without any problem... (to late now :))

Mon, 02/16/2009 - 14:39 (Reply to #16)
andreychek

Yeah, Joe's pretty good at not committing to a specific date, but there's an open bug regarding Debian 5 here:

http://www.virtualmin.com/index.php?option=com_fireboard&amp;Itemid=77&a...

Mon, 02/16/2009 - 21:46
Hal9000

u sure you pasted the right link? :)

Tue, 02/17/2009 - 04:06 (Reply to #18)