www not working

8 posts / 0 new
Last post
#1 Wed, 04/15/2009 - 15:06
paul.kelly

www not working

I am sure that this is a stupid, simple thing, but I cant work it out!

I have got my first site uploaded and working, but only when you use the URL. Add www. to the front and I get 'address not found'.

What have I done wrong?

Wed, 04/15/2009 - 15:09
andreychek

If you log onto your server using SSH, and type:

host www.YOUR_DOMAIN.com

Does it show an IP address, or do you get a "Not found" error?
-Eric

Wed, 04/15/2009 - 23:09 (Reply to #2)
duncanbbd

does this site give you any information on why the domain is not working ?
http://www.thednsreport.com/

Wed, 04/15/2009 - 23:14 (Reply to #3)
paul.kelly

I added the hosts DNS ipaddresses into bind/other dns servers and the non www access returned.

As for the report:

fail
All nameservers report identical NS records ERROR. The NS records at all your nameservers are different, check the info above for details.
fail
All nameservers respond ERROR: some nameservers does not respond
ns6.xxxxxx.net. [78.129.xx.xx] does not respond
(I have pinged and am getting a response)

fail
SOA MNAME Check ERROR: Your SOA (Start of Authority) record states that your master (primary) name server is: That server is not listed at the parent servers, which is not correct.

Wed, 04/15/2009 - 23:38 (Reply to #4)
duncanbbd

for the record, I'm no expert :o)

I'm setting up a new server and the domain settings are below, not sure if it helps.
also when did you make changes, sometimes it can take up to 24 hours for changes to propogate.

$ttl 38400
@ IN SOA domain.com. root.domain.com. (
1238925937
10800
3600
604800
38400 )
domain.com. IN A xx.xx.xx.xx
www.domain.com. IN A xx.xx.xx.xx
ftp.domain.com. IN A xx.xx.xx.xx
m.domain.com. IN A xx.xx.xx.xx
localhost.domain.com. IN A 127.0.0.1
webmail.domain.com. IN A xx.xx.xx.xx
admin.domain.com. IN A xx.xx.xx.xx
mail.domain.com. IN A xx.xx.xx.xx
domain.com. IN MX 5 mail.domain.com.
domain.com. IN TXT "v=spf1 a mx a:domain.com ip4:xx.xx.xx.xx -all"
ns.domain.com. IN A xx.xx.xx.xx
domain.com. IN NS a.ns.joker.com.
domain.com. IN NS b.ns.joker.com.
*.domain.com. IN A xx.xx.xx.xx

Thu, 04/16/2009 - 04:50 (Reply to #5)
andreychek

So, regarding the "www" -- that's usually just an alias, or CNAME, of the primary YOUR_DOMAIN.com record. You just have to make sure it exists in your hosts DNS.

The other issues are odd though :-)

It sounds like something is inconsistent about the DNS records or servers, but it's hard to say what exactly without knowing the specifics (ie, the name of the domain having trouble).

When the above errors say that a nameserver isn't responding, it's referring to responding to DNS queries specifically -- so if it weren't working properly, a ping may not show that.
-Eric

Wed, 04/15/2009 - 15:24
Joe
Joe's picture

So, we've been talking about DNS in another thread. What was the decision on that? Who is providing name service for your domain? If not the Virtualmin server, did you add an A record for www.domain.tld to the name servers?

--

Check out the forum guidelines!

Wed, 04/15/2009 - 22:54 (Reply to #7)
paul.kelly

At the moment, there have been no changes to the setup (where I did fiddle, I have returned back to where it was) and the I am using the hosts DNS.

Last night it worked for mydomain.com and not www.mydomain.com. Now it doesnt work on any!

Running the host command gets:
Host www.mydomain.com not found: 3(NXDOMAIN)