No mail goin out...help...postfix!!!

  • truenite
  • 06/09/08
  • Offline
Posted: Mon, 2008-06-09 06:33

Heres my error log

Jun 9 11:31:48 AKGServer postfix/smtp[10015]: fatal: open dictionary: expecting "type:name" form instead of "hash:" Jun 9 11:31:49 AKGServer postfix/master[9930]: warning: process /usr/libexec/postfix/smtp pid 10015 exit status 1 Jun 9 11:31:49 AKGServer postfix/master[9930]: warning: /usr/libexec/postfix/smtp: bad command startup -- throttling

plz im on mac os server....cant figure out whats going on...plz help!!


Re:No mail goin out...help...postfix!!!

  • Joe
  • 10/23/08
  • Offline
  • Mon, 2008-06-09 11:00

Misconfiguration. I suspect you've misconfigured the virtual_alias_maps field, but any other maps option could be wrong.

Maps are always configured in the form:

hash:/path/to/file

It looks like maybe you've just given it "hash:" without a path to a file. That'd be wrong. ;-)


Re:No mail goin out...help...postfix!!!

  • sgrayban
  • 06/20/07
  • Offline
  • Mon, 2008-06-09 23:35

Joe would be absolutely correct :)


Re:No mail goin out...help...postfix!!!

  • truenite
  • 06/09/08
  • Offline
  • Tue, 2008-06-10 02:21

help...now i've got this:

Jun 10 07:11:34 AKGServer postfix/qmgr[2476]: warning: private/local socket: malformed response Jun 10 07:11:34 AKGServer postfix/master[2474]: warning: process /usr/libexec/postfix/local pid 2618 exit status 1 Jun 10 07:11:34 AKGServer postfix/qmgr[2476]: warning: transport local failure -- see a previous warning/fatal/panic logfile record for the problem description Jun 10 07:11:34 AKGServer postfix/master[2474]: warning: /usr/libexec/postfix/local: bad command startup -- throttling Jun 10 07:11:34 AKGServer postfix/qmgr[2476]: warning: private/local socket: malformed response Jun 10 07:11:34 AKGServer postfix/master[2474]: warning: process /usr/libexec/postfix/local pid 2617 exit status 1 Jun 10 07:11:34 AKGServer postfix/qmgr[2476]: warning: transport local failure -- see a previous warning/fatal/panic logfile record for the problem description Jun 10 07:11:34 AKGServer postfix/error[2666]: warning: open active 5BBEB77AD5: No such file or directory Jun 10 07:11:34 AKGServer postfix/qmgr[2476]: warning: qmgr_active_corrupt: save corrupt file queue active id 5BBEB77AD5: No such file or directory Jun 10 07:11:34 AKGServer postfix/error[2665]: warning: open active 4821877AD4: No such file or directory Jun 10 07:11:34 AKGServer postfix/qmgr[2476]: warning: qmgr_active_corrupt: save corrupt file queue active id 4821877AD4: No such file or directory


Re:No mail goin out...help...postfix!!!

  • Joe
  • 10/23/08
  • Offline
  • Tue, 2008-06-10 10:17

I have no idea. I've never seen errors like that, but I'm guessing some directory configured for the queue doesn't exist or isn't writable by the user Postfix is running as. But that's just a guess.

How did you install Postfix?


Re:No mail goin out...help...postfix!!!

  • truenite
  • 06/09/08
  • Offline
  • Tue, 2008-06-10 04:21

and this mainly

Jun 10 08:56:12 AKGServer postfix/master[1186]: warning: process /usr/libexec/postfix/local pid 1212 exit status 1 Jun 10 08:56:12 AKGServer postfix/master[1186]: warning: /usr/libexec/postfix/local: bad command startup -- throttling Jun 10 08:56:12 AKGServer postfix/master[1186]: warning: process /usr/libexec/postfix/local pid 1214 exit status 1


Re:No mail goin out...help...postfix!!!

  • truenite
  • 06/09/08
  • Offline
  • Tue, 2008-06-10 10:59

leopard server


Re:No mail goin out...help...postfix!!!

  • sgrayban
  • 06/20/07
  • Offline
  • Tue, 2008-06-10 20:40

leopard server ??

How about expanding that to a OS or Distro


Re:No mail goin out...help...postfix!!!

  • truenite
  • 06/09/08
  • Offline
  • Wed, 2008-06-11 00:31

Mac OS server...more specifically Leopard...btw how can i change the outbox port for postfix?...


Re:No mail goin out...help...postfix!!!

  • truenite
  • 06/09/08
  • Offline
  • Wed, 2008-06-11 06:51

ok...i got port 25 open from my isp...i can send mails to gmail now...but not to much other...this is my error log...

Jun 11 11:35:55 AKGServer postfix/local[6641]: warning: connect #1 to subsystem private/cyrus: Connection refused Jun 11 11:35:55 AKGServer postfix/local[6640]: warning: connect #1 to subsystem private/cyrus: Connection refused Jun 11 11:36:05 AKGServer postfix/local[6641]: warning: connect #2 to subsystem private/cyrus: Connection refused Jun 11 11:36:05 AKGServer postfix/local[6640]: warning: connect #2 to subsystem private/cyrus: Connection refused Jun 11 11:36:15 AKGServer postfix/local[6641]: warning: connect #3 to subsystem private/cyrus: Connection refused Jun 11 11:36:15 AKGServer postfix/local[6640]: warning: connect #3 to subsystem private/cyrus: Connection refused Jun 11 11:36:25 AKGServer postfix/local[6641]: warning: connect #4 to subsystem private/cyrus: Connection refused Jun 11 11:36:25 AKGServer postfix/local[6640]: warning: connect #4 to subsystem private/cyrus: Connection refused Jun 11 11:36:35 AKGServer postfix/local[6641]: warning: connect #5 to subsystem private/cyrus: Connection refused Jun 11 11:36:35 AKGServer postfix/local[6640]: warning: connect #5 to subsystem private/cyrus: Connection refused Jun 11 11:36:45 AKGServer postfix/local[6641]: warning: connect #6 to subsystem private/cyrus: Connection refused Jun 11 11:36:45 AKGServer postfix/local[6640]: warning: connect #6 to subsystem private/cyrus: Connection refused Jun 11 11:36:55 AKGServer postfix/local[6641]: warning: connect #7 to subsystem private/cyrus: Connection refused Jun 11 11:36:55 AKGServer postfix/local[6640]: warning: connect #7 to subsystem private/cyrus: Connection refused


Re:No mail goin out...help...postfix!!!

  • velvetpixel
  • 01/10/08
  • Offline
  • Wed, 2008-06-11 08:22

truenite what's the system version of the OS

It would look like this: System Version: Mac OS X 10.5.? (????)

Fill in the question marks.


Re:No mail goin out...help...postfix!!!

  • Joe
  • 10/23/08
  • Offline
  • Wed, 2008-06-11 10:09

What are you using cyrus for?


Re:No mail goin out...help...postfix!!!

  • truenite
  • 06/09/08
  • Offline
  • Wed, 2008-06-11 11:10

im not sure...im not tryin to use it...as far as i know its only for recieving emails...and im not tryin to recieve any...so thats mostly my confusion...

and

System Version: Mac OS X 10.5. Server dunno if theres more digints after the 5...