Mailman notworking on newly installed server

Hello,

I reinstalled a virtualmin server. I restored some backups on that system. When I want to go to mailman. I get the message that it ran into a bug in Mailman version 2.1.9

Martin Koekenberg

Status: 
Active

Comments

What steps are you taking to go into Mailman? And can you copy/paste the exact error you're seeing, that would be helpful in diagnosing the issue. Thanks!

mlkoekenberg's picture
Submitted by mlkoekenberg on Wed, 08/25/2010 - 10:36 Pro Licensee

Hello,

I enter Virtualmin as master admin. Go to a domain -> services -> Mialinglists. There I click on the manage button. On that moment I get this error:

Bug in Mailman version 2.1.9

We're sorry, we hit a bug!

Please inform the webmaster for this site of this problem. Printing of traceback and other system information has been explicitly inhibited, but the webmaster can find this information in the Mailman error logs.

I'll create a temp login for you via Virtualmin.

Martin Koekenberg

mlkoekenberg's picture
Submitted by mlkoekenberg on Thu, 08/26/2010 - 09:01 Pro Licensee

Hello Andrey,

Anny progres? It's is a bug when a client is also login via the link in a moderator email. I reccieved allready several tickits with this bug message from my clients.

Groeten,

Martin Koekenberg

mlkoekenberg's picture
Submitted by mlkoekenberg on Thu, 08/26/2010 - 09:41 Pro Licensee

Adrey,

Problem is almost solved.....

The default install isn't creating the log folder (var/logs/mailman) with a file 'error' an the correct privilages.

This will generate the bug. Mailman can't write to a log file.

Now there is a logfile and the mail is sent correctly. But I get this in that log file:

Aug 26 16:17:37 2010 (1459) Archive file access failure: /var/lib/mailman/archives/private/nieuwsbrief-waterpolo-swol1894.mbox/nieuwsbrief-waterpolo-swol1894.mbox [Errno 2] No such file or directory: '/var/lib/mailman/archives/private/nieuwsbrief-waterpolo-swol1894.mbox/nieuwsbrief-waterpolo-swol1894.mbox' Aug 26 16:17:37 2010 (1459) Uncaught runner exception: [Errno 2] No such file or directory: '/var/lib/mailman/archives/private/nieuwsbrief-waterpolo-swol1894.mbox/nieuwsbrief-waterpolo-swol1894.mbox' Aug 26 16:17:38 2010 (1459) Traceback (most recent call last): File "/usr/lib/mailman/Mailman/Queue/Runner.py", line 112, in _oneloop self._onefile(msg, msgdata) File "/usr/lib/mailman/Mailman/Queue/Runner.py", line 170, in _onefile keepqueued = self._dispose(mlist, msg, msgdata) File "/usr/lib/mailman/Mailman/Queue/ArchRunner.py", line 73, in _dispose mlist.ArchiveMail(msg) File "/usr/lib/mailman/Mailman/Archiver/Archiver.py", line 200, in ArchiveMail self.__archive_to_mbox(msg) File "/usr/lib/mailman/Mailman/Archiver/Archiver.py", line 169, in __archive_to_mbox mbox = self.__archive_file(afn) File "/usr/lib/mailman/Mailman/Archiver/Archiver.py", line 157, in __archive_file return Mailbox.Mailbox(open(afn, 'a+')) IOError: [Errno 2] No such file or directory: '/var/lib/mailman/archives/private/nieuwsbrief-waterpolo-swol1894.mbox/nieuwsbrief-waterpolo-swol1894.mbox'

Aug 26 16:17:38 2010 (1459) SHUNTING: 1282599225.999341+1d5f5fc79f329cc72341b8251dc8879bf18a8415

Perhaps you need to create /var/lib/mailman/archives/private/nieuwsbrief-waterpolo-swol1894.mbox and make it world-writable?

mlkoekenberg's picture
Submitted by mlkoekenberg on Tue, 08/31/2010 - 08:38 Pro Licensee

That is the solution. But why isn't it restored when a backup with a mailmanlist is restored ?

A bug in the backup/restore feature ?

Martin

Actually, archives should already be included in the backup - assuming you check the box on the backup form to include them.