install script error on Debian 9, /etc/network/interfaces not there

Hi Virtualmin team,

I run into a problem when runing the install script on a freshly installed Debian 9 server.

The scripts ends up with an error because it is unable to find the /etc/network/interfaces file.

I contacted my provider's support (OVH) and they confirmed that, since 11/15/17, they changed the image with wich all servers are now installed. Naming the interfaces as eth0, eth1… has been abandoned and, from now on, systemd-network wil bee used.

As a result, the network confoguration now relies on /etc/network/50-default.network

Here is their doc (french, sorry): https://docs.ovh.com/fr/dedicated/network-ipaliasing/#debian-9-ubuntu-17...

Is there any quick (and clean :) workarround?

EDIT Oh, it turns out that simply creating the interfaces file (blank) makes the installation script happy... Is that it? It looks too simple :)

All the best! Nico

Status: 
Active

Comments

That's surprising - because even if you fix the installer, other parts of Virtualmin may run into trouble if /etc/network/interfaces doesn't exist.

Are you running Debian 9 there?

Yes it is surprising ... I confirm that it is a Debian 9 system and that Virtualmin seems to be runing fine. I did not test extensively yet, but creating a new Virtual Server works like a charm.

Not surprisingly, the "Activated at boot" tab of Webmin's "Network Interfaces" module does not show anything, but the "Active Now" tab shows an "eno1" interface with my actual IPv4 and IPv6 adresses.

If you would like acces to the server or some screenshots, just yell ;-)

Joe's picture
Submitted by Joe on Sun, 11/26/2017 - 06:12 Pro Licensee

I'm gonna fire up an OVH VPS and see what that looks like. It's likely we'll need some tweaks to both the installer and to Virtualmin. It's weird I didn't see this on any of my Debian 9 test systems, but fixing the installer will be easy...fixing Virtualmin/Webmin maybe slightly less easy.

I just did the same: I installed a new VPS a few minutes ago ... and the /etc/network/interfaces file IS present.

Obviously, the Debian 9 image with wich they install their VPS is not the same as the one used to install dedicated servers :-/

Hello all,

I have the same error with fresh install (debian 9.3) on OVH server.

Like Nico94, I try a new install, create a new blank file '/etc/network/interfaces' and installation script run fine.

Can i use my server like this or not ? Any other change to do after install ?

Thanks

PS : sorry for my basic english

Yeah it should be no problem to use Virtualmin; I think the biggest issue to watch out for is when adding new IP addresses to your server.

If you have Virtualmin add a new IP, it wouldn't understand how to go about that, and would try adding it to the "interfaces" file.

What you may want to do instead is manually add any new IP's to your server until Virtualmin is modified to handle the different configuration that they're using there.

I have error when i try to run composer self-update

[Composer\Downloader\TransportException]   The "https://getcomposer.org/versions" file could not be downloaded: failed    to open stream: Connection timed out

I find this post https://getcomposer.org/doc/articles/troubleshooting.md#operation-timed-...

i go to Webmin > Networking > Network Configuration > Host Addresses IPv6 for my server hostnamame was 127.0.1.1.

I updated with the correct server IPv6 and now, composer self-update run fine.

Is it a good way to do ? is it a relative issue of this install error ?

Thanks

I take new dedicated server from OVH with Debian 9. I can confirm /etc/network/interfaces not there and installation fails.