Install script osTicket dont work

I get this when installing osTicket with script from virtualmin:

Descarregando http://scripts.virtualmin.com/osTicket-v1.9.16.zip (6.83 MB) ..
     Recebido 1024 bytes (0 %)
     Recebido 700 kB (10 %)
     Recebido 1.37 MB (20 %)
     Recebido 2.05 MB (30 %)
     Recebido 2.73 MB (40 %)
     Recebido 3.41 MB (50 %)
     Recebido 4.10 MB (60 %)
     Recebido 4.78 MB (70 %)
     Recebido 5.46 MB (80 %)
     Recebido 6.15 MB (90 %)
     Recebido 6.83 MB (100 %)
.. descarga completa.

Configuring webserver PHP settings ..
.. already done.
Applying web server configuration ..
.. done

Now installing osTicket version 1.9.16 ..
Installer page failed : HTTP/1.1 500 Internal Server Error
More information on using this script can be found at http://osticket.com/.

.. installation was only partially complete.
Re-loading Webmin ..
.. done

Applying web server configuration ..
.. done
Status: 
Active

Comments

Howdy -- thanks for contacting us!

This looks like a similar issue to the other request -- the app is generating a 500 error, which means that there would be an error in the Apache error logs. What error is showing up in $HOME/logs/error_log when attempting to install that script?

brunno's picture
Submitted by brunno on Sat, 03/30/2019 - 19:48 Pro Licensee

Hi,

Although it looks like the other problem, they are different problems and different scripts: [Sat Mar 30 21:16:58.584479 2019] [fcgid:warn] [pid 22665:tid 140108395820800] [client 129.213.180.52:40484] mod_fcgid: stderr: PHP Warning:  "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"? in /home/brunno.bsb.br/public_html/osticket/include/class.osticket.php on line 425
[Sat Mar 30 21:16:58.584508 2019] [fcgid:warn] [pid 22665:tid 140108395820800] [client 129.213.180.52:40484] mod_fcgid: stderr: PHP Fatal error:  Cannot declare class Error, because the name is already in use in /home/brunno.bsb.br/public_html/osticket/include/class.error.php on line 43
brunno's picture
Submitted by brunno on Fri, 04/05/2019 - 11:57 Pro Licensee

Hi,

I tried to install it with php 5.6, but still dont install:

Descarregando http://scripts.virtualmin.com/osTicket-v1.9.16.zip (6.83 MB) ..
     Recebido 1024 bytes (0 %)
     Recebido 700 kB (10 %)
     Recebido 1.37 MB (20 %)
     Recebido 2.05 MB (30 %)
     Recebido 2.73 MB (40 %)
     Recebido 3.41 MB (50 %)
     Recebido 4.10 MB (60 %)
     Recebido 4.78 MB (70 %)
     Recebido 5.46 MB (80 %)
     Recebido 6.15 MB (90 %)
     Recebido 6.83 MB (100 %)
.. descarga completa.

Configuring webserver PHP settings ..
.. already done.
Now installing osTicket version 1.9.16 ..
osTicket configuration failed
More information on using this script can be found at http://osticket.com/.

.. installation was only partially complete.
Re-loading Webmin ..
.. done

Jamie, it looks like we're offering osTicket 1.9.16, there appears to be a newer version though, 1.11. Is that something we can include in our Install Scripts?

https://osticket.com/download/