Install Scripts: Tiki Wiki CMS Groupware (tiki.org) versions are outdated

The Virtualmin app installer offers a few versions of Tiki Wiki CMS Groupware, the most recent being 19.x

The latest stable version is 22.x -> https://tiki.org/download but I suggest to only offer Long Term Support (LTS) versions, the latest being 21.x LTS, and in the future 24.x LTS. Tiki 21.x LTS is supported until March 2025: https://doc.tiki.org/Tiki21

Tiki started in 2002, and since 2009 offers Long Term Support (LTS) versions. The time-based, "Release early, Release often" approach with LTS versions permits to balance the needs of stability and innovation. Please see: https://tiki.org/Versions

For a flashback to 2005, please see: https://forum.virtualmin.com/t/tip-create-new-script-installers-for-your...

I am a contributor to the Tiki community so I am happy to help in any way.

Best regards,

Marc

Marc Laporte

WikiSuite.org Founder, Tiki.org Admin, EvoluData.com CEO

Status: 
Fixed (pending)
Virtualmin version: 
6.16
Webmin version: 
1.973

Comments

Ilia's picture
Submitted by Ilia on Thu, 04/29/2021 - 09:37

Hi, Marc.

Thanks for the heads up.

In fact, each and every install script is getting revised and fixed at the moment. This is what I have been doing for the past 10 days.

I will reach Tiki pretty soon.

Ilia's picture
Submitted by Ilia on Thu, 04/29/2021 - 14:27

TikiWiki current version available for installation is 22.1.