Webmin not using the current certificate

2 posts / 0 new
Last post
#1 Sat, 10/21/2017 - 04:56
Jake404

Webmin not using the current certificate

I recently started using Webmin/Virtualmin and everything is working perfectly except for the SSL certificate for Webmin itself. I have searched online and in the forum and found no solutions to my problem. I'm trying to use Let's Encrypt for Webmin and I have setup a virtual server for the same hostname as Webmin. Let's Encrypt does it's job and the certificate is copied over to /etc/webmin. If I check under 'Current Certificate' in Webmin configuration it says that it is using the Let's Encrypt certificate and the hostname is correct. However when I browse to Webmin it's still using a self-signed wildcard certificate. 2017_10_21_11_50_03

If I try to save the SSL settings it says: Failed to save SSL options : The SSL private key file /etc/webmin/xxxxxxxx.key does not exist or does not contain a PEM format key 2017_10_21_11_50_57

I checked the path it's referring to and the key, cert and chain files are there. I checked the permissions for them and they are set to 0600 and the owner is root/root.

I have restarted Webmin and rebooted the server.

Does anyone have any suggestions on fixing this problem?

EDIT: I uploaded a new certificate and it saved correctly and it's showing up under 'Current certificate' but when browsing to Webmin still using the self-signed certificate. I still can't change anything under 'SSL Settings'. It says the same thing as above: Failed to save SSL options : The SSL private key file /etc/webmin/xxxxxxxx.key does not exist or does not contain a PEM format key

Mon, 11/13/2017 - 07:10
ashleydrees Pro Licensee

I too am having issues with this....

1, I created virtual host with the same/domain name... and the virtual host applies its cert to postfix/dovecot/ftp fine, but when it comes to webmin (does not apply it to usermin either) it fails with the " does not exist or does not contain a PEM format key" 2 when when i make what i consider to be a valid PEM file outside of webmin (copy from the virtual domain) and place it in the /etc/webmin folder it reports this same issue on restarting. 3 I have tried to create a cert INSIDE the webmin config tab - it allows me to do that but then gives this error when I try and turn SSL on.

The files are put in the correct locations and the miniserv.conf is updated - BUT - if I do 1, then the files are owned by the user and group that owns the virtual server. I did change the owner and group to the same as other files in the folder, but it makes no difference.