Postfix SMTPS running error , Please help

I am going to setup the smps on my postfix server . And done the setting of SMTPS configure setting. Telnet to 465 Port is normal. nmap command find that the 465 port is ready and open.

But when i using outlook to send mail via ssl get error

ERROR CODE : 0x800CCC0F

/var/log/maillog show the following error.

Nov 25 04:09:22 sfasvr25 postfix/smtpd[32191]: warning: TLS library problem: 32191:error:1408A0C1:SSL routines:SSL3_GET_CLIENT_HELLO:no shared cipher:s3_srvr.c:975:

Pleaes help ...is it the postfix setting incorrect ? or another problem

Status: 
Active

Comments

Howdy -- can you attach your config files, /etc/postfix/main.cf and /etc/postfix/master.cf? Thanks!

Dear Andreychek ,

Here is my main and master file.

Please Note and help.

What happens if you comment out this line in your main.cf file:

smtpd_tls_cert_file = none

And then restart Postfix with:

/etc/init.d/postfix restart

Dear Andrey ,

I have remark this line in main.cf . Also can't using SSL.

The maillog show as below

#

Nov 27 02:44:48 sfasvr25 postfix/smtpd[30248]: warning: Wrapper-mode request dropped from unknown[203.132.207.161] for service smtps. TLS context initialization failed. For details see earlier warnings in your logs.

#

the main.cf and master.cf file setting is correct or not ? this is seem the library problem.... TLS contect problem ?

Before we dig into the specifics of your Postfix config too much -- is your saslauthd daemon running?

You can verify that by running this command:

/etc/init.d/saslauthd start

Without that, you could get some odd errors while trying to connect.

Dear Andy ,

The saslauthd is running. i telnet to my server port 25 is show as below ehlo localhost 250-PIPELINING 250-SIZE 15360000 250-VRFY 250-ETRN 250-STARTTLS 250-AUTH PLAIN LOGIN 250-AUTH=PLAIN LOGIN 250-ENHANCEDSTATUSCODES 250-8BITMIME 250 DSN