Login to virtualmin issue

20 posts / 0 new
Last post
#1 Wed, 03/31/2010 - 10:39
KrishManohar

Login to virtualmin issue

Hello,

Any help will be appreciated. I have search an found no answer.

When trying to login as a regular created user into virtualmin i get this error "Login failed. Please try again." for all users except ROOT.

I can login as Root fine, but any other user created before or now cannot login for some odd reason.

If anyone got a solution or ideas please help!

Thanks, Krish Manohar

Wed, 03/31/2010 - 10:42
andreychek

Howdy,

Hmm... what OS or Linux distribution and version are you using? And did you do the install with the install.sh script?

Are you using anything like MySQL or LDAP for usernames and passwords, or are you just using the standard /etc/passwd file?

Do any errors show up in the logs when you try to log in? Can the users you create login via FTP?

I think that's about it for my questions ;-) Thanks!

-Eric

Wed, 03/31/2010 - 10:51
KrishManohar

Thank you for the fast respond.

Hmm... what OS or Linux distribution and version are you using? And did you do the install with the install.sh script?

Yes I used install.sh (login worked for first few weeks)

Are you using anything like MySQL or LDAP for usernames and passwords, or are you just using the standard /etc/passwd file?

PAM for Unix authentication (if this make sense) or point me where to check.

Do any errors show up in the logs when you try to log in? Can the users you create login via FTP? Not sure where i can check error on this either.

Wed, 03/31/2010 - 11:24
andreychek

Howdy,

Not sure where i can check error on this either.

Well, I can help, but you missed the question about which OS/distro and version you're using -- I'll need that info in order to direct you to the correct logfiles :-)

-Eric

Wed, 03/31/2010 - 11:27
KrishManohar

I am using CentOS 5.4

Here is few errors i got from /var/webmin/miniserv.error: [24/Mar/2010:04:21:56 +0000] Continuing without the Authen::PAM perl module Error: Missing or invalid backup filename Error: Missing or invalid table name [30/Mar/2010:20:53:56 +0000] Reloading configuration [30/Mar/2010:21:04:18 +0000] [98.249.218.93] /session_login.cgi : Access denied for 98.249.218.93. The host has been blocked because of too many authentication failures. [30/Mar/2010:21:04:28 +0000] [98.249.218.93] Access denied for 98.249.218.93 restarting miniserv [30/Mar/2010:21:16:46 +0000] Restarting [30/Mar/2010:21:16:46 +0000] miniserv.pl started [30/Mar/2010:21:16:46 +0000] Perl module Authen::PAM needed for PAM is not installed : Can't locate Authen/PAM.pm in @INC (@INC contains: /usr/libexec/webmin /usr/lib64/perl5/site_perl/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl /usr/lib64/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl /usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi /usr/lib/perl5/5.8.8 .) at (eval 10) line 1. BEGIN failed--compilation aborted at (eval 10) line 1.

Thu, 04/01/2010 - 11:29
KrishManohar

Anyone else? I think andreychek forgot about me :(

Thu, 04/01/2010 - 11:46
andreychek

The two things I would do are:

  1. First check to see if the users can login via FTP. That will show whether they work at all

  2. After trying to login into Virtualmin, look in /var/log/secure and perhaps /var/log/messages for any errors.

    -Eric

Thu, 04/01/2010 - 13:15
KrishManohar

#

First check to see if the users can login via FTP. That will show whether they work at all

Yes

#

After trying to login into Virtualmin, look in /var/log/secure and perhaps /var/log/messages for any errors.

/var/log/secure log: Apr 1 18:11:54 ns1 webmin[27642]: Logout by root from 98.64.135.80 Apr 1 18:13:40 ns1 webmin[27643]: Invalid login as agnima from 98.64.135.80 Apr 1 18:13:48 ns1 webmin[27644]: Successful login as root from 98.64.135.80

/var/log/messages: Apr 1 17:35:48 ns1 named[1071]: client 205.152.132.39#7463: query (cache) 'ns12.agnihost.com/AAAA/IN' denied Apr 1 17:35:48 ns1 named[1071]: client 205.152.132.39#53185: query (cache) 'ns11.agnihost.com/AAAA/IN' denied Apr 1 17:35:54 ns1 named[1071]: client 205.152.144.11#14326: query (cache) 'ns12.agnihost.com/AAAA/IN' denied Apr 1 17:35:54 ns1 named[1071]: client 205.152.144.11#65024: query (cache) 'ns11.agnihost.com/AAAA/IN' denied Apr 1 17:35:54 ns1 named[1071]: client 205.152.144.11#38963: query (cache) 'ns11.agnihost.com/AAAA/IN' denied Apr 1 17:35:54 ns1 named[1071]: client 205.152.144.11#11282: query (cache) 'ns12.agnihost.com/AAAA/IN' denied Apr 1 17:36:03 ns1 named[1071]: client 205.152.132.34#10347: query (cache) 'ns11.agnihost.com/AAAA/IN' denied Apr 1 17:36:03 ns1 named[1071]: client 205.152.132.34#42712: query (cache) 'ns12.agnihost.com/AAAA/IN' denied Apr 1 17:36:03 ns1 named[1071]: client 205.152.132.34#54170: query (cache) 'ns11.agnihost.com/AAAA/IN' denied Apr 1 17:36:03 ns1 named[1071]: client 205.152.132.34#41943: query (cache) 'ns12.agnihost.com/AAAA/IN' denied Apr 1 17:36:06 ns1 named[1071]: client 205.152.144.41#24779: query (cache) 'ns11.agnihost.com/AAAA/IN' denied Apr 1 17:36:06 ns1 named[1071]: client 205.152.144.41#46259: query (cache) 'ns12.agnihost.com/AAAA/IN' denied Apr 1 17:36:06 ns1 named[1071]: client 205.152.144.41#8238: query (cache) 'ns11.agnihost.com/AAAA/IN' denied Apr 1 17:36:06 ns1 named[1071]: client 205.152.144.41#31599: query (cache) 'ns12.agnihost.com/AAAA/IN' denied Apr 1 17:46:39 ns1 proftpd[27150]: ns1.agnima.com (::ffff:98.64.135.80[::ffff:98.64.135.80]) - FTP session opened. Apr 1 18:11:28 ns1 named[1071]: client 93.158.150.250#5335: query (cache) 'www.agnihost.com/A/IN' denied Apr 1 18:11:28 ns1 named[1071]: client 93.158.150.250#5335: query (cache) 'www.agnihost.com/A/IN' denied Apr 1 18:11:28 ns1 named[1071]: client 93.158.148.250#5335: query (cache) 'www.agnihost.com/A/IN' denied Apr 1 18:11:28 ns1 named[1071]: client 93.158.148.250#5335: query (cache) 'www.agnihost.com/A/IN' denied Apr 1 18:11:29 ns1 named[1071]: client 93.158.151.250#5335: query (cache) 'www.agnihost.com/A/IN' denied

Fri, 04/02/2010 - 12:25
KrishManohar

Any other idea?

Fri, 04/02/2010 - 12:37
ronald
ronald's picture

webmin[27643]: Invalid login as agnima from
does this user have the webmin login enabled under allowed features of that domain?
are the credentials correct? as it doesnt say denied but invalid...

Also check if that user is temporarily blocked from webmin (I had that once unexpectedly) - webmin users - click the users name in question.

Fri, 04/02/2010 - 12:49
KrishManohar

does this user have the webmin login enabled under allowed features of that domain? are the credentials correct? as it doesnt say denied but invalid...

Yes the user have it.

Also check if that user is temporarily blocked from webmin (I had that once unexpectedly) - webmin users - click the users name in question.

Not blocked

Mon, 08/30/2010 - 06:58
RedKnot

Hi,

I have exactly the same issue. I use opensolaris 11 and LDAP. I can login as root en use webmin/virtualmin but other users can't. Login with imap or ftp is successful for those users. I can't find any logs about login attempts in /var/log, var/adm or /var/webmin. I got warnings about missing PAM module for Perl but since I installed that module no warnings any more.

What could cause this issue???

Thu, 10/07/2010 - 10:26
bizmate

Hi

I have a similar but opposite issue I can access virtualmin with the domain user but I cannot access with root anymore. This just happened suddenly and the Pam module was failing before

logs from /var/log/secure Oct 7 16:14:13 ip-10-226-55-115 webmin[2270]: Security alert: Host 212.183.140.92 blocked after 5 failed logins for user root Oct 7 16:14:13 ip-10-226-55-115 webmin[3543]: Invalid login as root from 212.183.140.92 Oct 7 16:15:01 ip-10-226-55-115 crond[3550]: pam_loginuid(crond:session): set_loginuid failed opening loginuid Oct 7 16:15:01 ip-10-226-55-115 crond[3553]: pam_loginuid(crond:session): set_loginuid failed opening loginuid Oct 7 16:15:07 ip-10-226-55-115 su: pam_unix(su:session): session opened for user postgres by (uid=0) Oct 7 16:15:07 ip-10-226-55-115 su: pam_unix(su:session): session closed for user postgres Oct 7 16:15:49 ip-10-226-55-115 webmin[3670]: Invalid login as root from 212.183.140.92

I see the problems with pam, is is possible that this is suddenly caused by PAM? I tried to install pam with yum (CentOS) but yum would get stuck

I also changed the root password but that made no difference on the virtualmin login

Thu, 10/07/2010 - 10:30
andreychek

One thing you may want to try is restarting Webmin... it looks like at some point in all that, it began blocking the root user after too many failed login attempts.

I'd suggest restarting Webmin just to make sure you've cleared the block, and then try it again with your updated password and see what happens.

You can restart Webmin by typing "/etc/init.d/webmin restart".

-Eric

Tue, 10/12/2010 - 10:52
bizmate

Hi Eric

thanks a lot for replying to these posts. I have tried both a machine restart as well as webmin restarts but they do not make any difference. Somehow the root user is locked or cannot log in and I do not know where to check why this is happening. /var/log/secure shows still the same failed login error but the login password is right as I can access from SSH. Is it possible that the user password and its webmin pass are somehow desynched?

Cheers

Diego

Fri, 10/15/2010 - 05:30
bizmate

Hi

the problem described in the posts above is not fixed yet and I still keep on getting errors.

Is there any file or setting that I can access through SSH or SFTP to enable another master user?

Cheers

Fri, 10/15/2010 - 08:29
andreychek

I'm curious what happens if you were to log into Virtualmin, go into Webmin -> System -> Change Passwords, and change the password for root. It's possible that somehow, something got out of sync, and changing the password from within Webmin might just fix that.

-Eric

Fri, 10/15/2010 - 09:10 (Reply to #17)
bizmate

Hi Eric

how can you do that if the root user cannot access it in the first place?

Diego

Fri, 10/15/2010 - 09:13
andreychek

Right... you raise a good point :-)

(should have had more coffee more replying!)

Okay, how about this... we can do the same thing, but using the command line tools.

Try running this:

virtualmin change-password

And update the password for root there.

-Eric

Fri, 10/15/2010 - 09:43
bizmate

Somehow it says it is not a virtualmin user

virtualmin change-password root Username: Old password: PASSSSSSSS New password: PASSSSSSSS Not a Virtualmin user

Also running virtualmin list-users --all-domains --include-owner

only gives me the other users (like domain owner and FTP user in the domain)

Before I attempt to add root as a user it be nice to know what you think about it ... sorry for the endless trouble

Cheers