"apply zone" doesn't work

20 posts / 0 new
Last post
#1 Tue, 01/04/2011 - 10:24
lex

"apply zone" doesn't work

Hi, I'm following this:

From Zero to Awesome: A Common-Sense Guide to Virtualmin Installation http://www.virtualmin.com/node/111

and sofar, so good. However, at "DNS / Nameserver setup", the very last line; "To make these active, click "Apply Zone" on the top-right".", I get this error:

NDC command failed : rndc: connect failed: 127.0.0.1#953: timed out

How do I proceed? As in, how do I solve this? Tried google but didn't get much wiser.

Thanks!

edit: hmm, just found out can't ping either on the machine, did work before installing virtualmin. So what could have caused this?

Tue, 01/04/2011 - 10:52
lex

ok, it was an iptables thing

it's all working now.

Sorry.

Tue, 01/04/2011 - 12:35
Locutus

iptables was blocking localhost? Mmm-kay. ;)

Wed, 01/05/2011 - 12:20 (Reply to #3)
lex

well, i restored the default iptables thing from the server and then it worked. What didn't work, was virtualmin, but with a rule i once asked for on here I got that working too.

Wed, 01/05/2011 - 12:26
lex

Another question; when the server was delivered, it had a default system hostname, which i couldn't change yet as the domain name that I reserved for it was still not available for a few hours.

So, I followed the steps here: From Zero to Awesome: A Common-Sense Guide to Virtualmin Installatio and everything seems to work.

However, I get this:

Glue is not provided by your nameservers. This means they did not provide the IP address of your nameservers, so an extra step may be required to resolve your domain. The following nameservers did not have glue:

server88-208-193-145.live-servers.net

You should add A records for your nameservers into your domain zone to fix this.

I have:

Your NS records at your nameservers are:

ns2.penghosting.nl reported: server88-208-193-145.live-servers.net [no glue] TTL 38400

ns1.penghosting.nl reported: server88-208-193-145.live-servers.net [no glue] TTL 38400

I wouldn't mind if in stead of "server88-208-193-145.live-servers.net" I'd have ns1.penghosting.nl for example. Can I do that?

I've seen at Webmin - Servers - Bind DNS Server:

Default nameserver for master domains System hostname (server88-208-193-145.live-servers.net)

Can I change it here or could I solve this at the root it self and change the 'server' name?

Thanks!

Thu, 01/06/2011 - 07:20
Locutus

As far as I understand the warning, it wants your nameservers to have A records for the hostnames that are listed as NS for the domain. To make sure we're talking about the same thing and so that I can do some diging: can you re-iterate which domain is the one in question, as in the one you're hosting and trying to resolve?

Thu, 01/06/2011 - 14:41
lex

Hi Locutus,

the server came with "server88-208-193-145.live-servers.net"

the domain I'd like to be the main one is: penghosting.nl

So sites with nameservers ns1.penghosting.nl and ns2.penghosting.nl are sent to the server. Would be nice if it would be called something with penhosting.nl in stead of server88-208-193-145.live-servers.net.

Does this help?

Thu, 01/06/2011 - 15:29
Locutus

I guess the best would be to set the system hostname in Webmin to the actual external one you wish to use now, then check the Server Template -> BIND DNS Domain in Virtualmin that it is set to use the system's hostname as primary nameserver, and then turn the feature "DNS Domain" off and on again so that it creates new zonefiles.

Otherwise you can manually fix the zones too of course. :)

Tue, 01/11/2011 - 07:40
lex

Thankns Locutus.

I did that, yesterday, but I still get these errors, so I guess I must have missed something somewhere:

Missing nameservers reported by parent FAIL: The following nameservers are listed at your nameservers as nameservers for your domain, but are not listed at the parent nameservers (see RFC2181 5.4.1). You need to make sure that these nameservers are working.If they are not working ok, you may have problems! server88-208-193-145.live-servers.net

Missing nameservers reported by your nameservers ERROR: One or more of the nameservers listed at the parent servers are not listed as NS records at your nameservers. The problem NS records are: ns1.penghosting.nl ns2.penghosting.nl This is listed as an ERROR because there are some cases where nasty problems can occur (if the TTLs vary from the NS records at the root servers and the NS records point to your own domain, for example).

http://www.intodns.com/gran-canaria-info.com

hmmmm, I wish I knew where to go now. Anyone an idea? Thanks!

Tue, 01/11/2011 - 07:42 (Reply to #9)
lex

At dnssy they put it this way:

Your nameservers returned different nameserver records.

At your nameservers I found: server88-208-193-145.live-servers.net At parent nameserver I found: ns1.penghosting.nl ns2.penghosting.nl

http://dnssy.com/report.php?q=gran-canaria-info.com

Tue, 01/11/2011 - 17:42
Locutus

Check out Webmin -> Servers -> BIND DNS Server -> -> Type: All and see what is listed as "NS" records there.

If that's the "server88..." thing, then you still have the incorrect hostname somewhere in your Virtualmin config, possibly the Server Template -> BIND DNS Domain.

Tue, 01/11/2011 - 18:46
lex

yep, it is the server88 thing.

I'll now look for "server template" etc

thanks!

Tue, 01/11/2011 - 18:56
lex

it says:

"Master DNS server hostname Automatic (from system's hostname)"

there, so I'm now off to see if somehow the 'system hostname' is still the old one. If not, I guess I have to go into each server and change this master dns server hostname.

Tue, 01/11/2011 - 19:12
lex

system hostname was fine, so I'm now changing at the servers: Services - DNS Domain - Edit Zone Parameters

where the old 'thing' still was, into 'penghosting.nl.' and i'm not sure if i should put ns1. in front of that or not...

Tue, 01/11/2011 - 19:20
lex

hmmm

so i did change it into ns1.penghosting.nl. and that seems better. Some things have improved on:

http://www.intodns.com/gran-canaria-info.com

However, I still get this:

Missing nameservers reported by parent

FAIL: The following nameservers are listed at your nameservers as nameservers for your domain, but are not listed at the parent nameservers (see RFC2181 5.4.1). You need to make sure that these nameservers are working.If they are not working ok, you may have problems! server88-208-193-145.live-servers.net

Missing nameservers reported by your nameservers

ERROR: One or more of the nameservers listed at the parent servers are not listed as NS records at your nameservers. The problem NS records are: ns1.penghosting.nl ns2.penghosting.nl

and

Stealth NS records sent Stealth NS records were sent: server88-208-193-145.live-servers.net

This is listed as an ERROR because there are some cases where nasty problems can occur (if the TTLs vary from the NS records at the root servers and the NS records point to your own domain, for example).

Maybe I should look into this tomorrow, as it's almost 1:30 and i'm becoming too tired.

Tue, 01/11/2011 - 19:30
lex

Hmm, in penghosting.nl "edit records file" I found this:

$ttl 38400
penghosting.nl. IN SOA ns1.penghosting.nl. lex.peng.nl. (
1294151142
10800
3600
604800
38400 )
@ IN NS server88-208-193-145.live-servers.net.
penghosting.nl. IN A 88.208.193.145
www.penghosting.nl. IN A 88.208.193.145
ftp.penghosting.nl. IN A 88.208.193.145
m.penghosting.nl. IN A 88.208.193.145
localhost.penghosting.nl. IN A 127.0.0.1
webmail.penghosting.nl. IN A 88.208.193.145
admin.penghosting.nl. IN A 88.208.193.145
mail.penghosting.nl. IN A 88.208.193.145
penghosting.nl. IN MX 5 mail.penghosting.nl.
penghosting.nl. IN TXT "v=spf1 a mx a:penghosting.nl ip4:88.208.193.145 ?all"
ns1.penghosting.nl. IN A 88.208.193.145
ns2.penghosting.nl. IN A 88.208.193.146

So that server88 thing is still there...

Driving me mad now.

Any idea how to change this 'globally' or should I just do it in here?

Tue, 01/11/2011 - 19:35
lex

ok, i changed them in the place you suggested in your last post in this thread.

http://www.intodns.com/gran-canaria-info.com is looking better already.

Now I'm left with this:

"ERROR: One or more of the nameservers listed at the parent servers are not listed as NS records at your nameservers. The problem NS records are: ns2.penghosting.nl This is listed as an ERROR because there are some cases where nasty problems can occur (if the TTLs vary from the NS records at the root servers and the NS records point to your own domain, for example)."

Tue, 01/11/2011 - 19:48
lex

hmm, in addition to that, when i try to setup a german domain for a client, I get this:

Command failed; [53300102912 Nameserver error [ERROR: 118 Inconsistent set of NS RRs (IP\, NS host names) (server88-208-193-145.live-servers.net/88.208.193.145\, \[ns1.penghosting.nl\])]]

before the changes of tonight, that said:

Command failed; [53300102912 Nameserver error [ERROR: 118 Inconsistent set of NS RRs (IP\, NS host names) (server88-208-193-146.live-servers.net/88.208.193.146\, \[server88-208-193-145.live-servers.net\])]]

SO, I guess the question now is how to sort the ns2 out...

Wed, 01/12/2011 - 04:18
lex

hmmm

it's definitely wrong but I don't see how to solve it:

Nameserver IPs ns1.penghosting.nl 88.208.193.145 ns2.penghosting.nl 88.208.193.146

Severity Code Message / Parameters

Error 118 Inconsistent set of NS RRs (IP, NS host names) server88-208-193-146.live-servers.net/88.208.193.146 [ns1.penghosting.nl]

Error 118 Inconsistent set of NS RRs (IP, NS host names) server88-208-193-145.live-servers.net/88.208.193.145 [ns1.penghosting.nl]

It seems it has to do with both ns1.penghosting.nl and ns2.penghosting.nl point to ns1.penghosting.nl

What am I to do? Anybody an idea?

Wed, 01/12/2011 - 04:41
lex

hmm, i added ns2.penghosting.nl. as a nameserver for the zone gran-canaria-info.com and that seems to have done the trick.

Let's test.

Topic locked