Domain accessed in browser only with IP, not with domain name.

  • vpapadop
  • 01/24/12
  • Offline
Posted: Tue, 2012-01-24 15:55

Hello,

I have a VPS with 2 available IPs and totally 5 Virtual servers.

IPs:

  • 1.2.3.1

  • 1.2.3.2

Domains:

  • example1.com

  • example2.com

  • example3.com

  • example4.com

  • sub.example2.com

I had created the 4 first domains using the default IP and I wanted to create the 5th domain (sub.example2.com) by assigning the second available IP.

When the installation of the virtual server finished i could access the domain via browser only by typing the IP address. When i type the domain name in the browser, i get the main domain page (example1.com) which was first created in the VPS (the default virtual server).

What i am trying to is to create sub.example2.com virtual server with the new IP 1.2.3.2 and also send mails coming from user@sub.example2.com from the same IP (1.2.3.2).

Could you please help me correct this problem?

Thank you in advance, Vasilis.


Howdy, What i am trying to

  • andreychek
  • 01/05/09
  • Offline
  • Sat, 2012-01-28 17:02

Howdy,

What i am trying to is to create sub.example2.com virtual server with the new IP 1.2.3.2 and also send mails coming from user@sub.example2.com from the same IP (1.2.3.2).

What you would want to do is, when creating the new Virtual Server -- go into the "IP Address and Forwarding" section, and enter the new IP in the "Network interface" field.

Also, remember that when changing a domain's IP address, your DNS may cache the old IP address for a day or two... so for testing, you may want to try it from a different computer.

-Eric