[Solved]Mail from Postfix goes into spam in gmail

11 posts / 0 new
Last post
#1 Sat, 08/04/2012 - 02:43
compfellows

[Solved]Mail from Postfix goes into spam in gmail

Hello, I setup Virtualmin in centos 6. I have setup a SOA as follows: v=spf1 a mx a:domain.com mx:domain.com ip4:x.x.x..34 ip4:x.x.x.35 -all

But all mails sent to a gmail account go to spam. The info in gmail is as follows:

Delivered-To: gmailid@gmail.com
Received: by 10.231.186.223 with SMTP id ct31csp251063ibb;
        Sat, 4 Aug 2012 00:37:42 -0700 (PDT)
Received: by 10.50.181.136 with SMTP id dw8mr640607igc.31.1344065862361;
        Sat, 04 Aug 2012 00:37:42 -0700 (PDT)
Return-Path: <support@domain.com>
Received: from host.domain.com ([x.x.x.34])
        by mx.google.com with ESMTP id wo5si874626igc.46.2012.08.04.00.37.42;
        Sat, 04 Aug 2012 00:37:42 -0700 (PDT)
Received-SPF: pass (google.com: domain of support@domain.com designates x.x.x.34 as permitted sender) client-ip=x.x.x.34;
Authentication-Results: mx.google.com; spf=pass (google.com: domain of support@domain.com designates x.x.x.34 as permitted sender) smtp.mail=support@domain.com
Received: from xPC (unknown [x.x.x.x])
by host.domain.com (Postfix) with ESMTPA id F3C8C7E63E5
for <gmailid@gmail.com>; Sat,  4 Aug 2012 11:37:17 +0400 (MSD)
From: "domain Support" <support@domain.com>
To: <gmailid@gmail.com>
Subject: Test email
Date: Sat, 4 Aug 2012 13:07:26 +0530
Message-ID: <002f01cd7214$008d6030$01a82090$@com>
MIME-Version: 1.0
Content-Type: multipart/alternative;
boundary="----=_NextPart_000_0030_01CD7242.1A459C30"
X-Mailer: Microsoft Office Outlook 12.0
Thread-Index: Ac1yE/4aCyxTfKQfSzS5XcyhCDwCCA==
Content-Language: en-us
x-cr-hashedpuzzle: ALgc A1vv BVDz Bo8P B0gI B3qc CYdh CoSc D72f EyuM GHVC GZGx HHKO Hdd/ IABs JBSD;1;YwBvAG0AcABmAGUAbABsAG8AdwBzAEAAZwBtAGEAaQBsAC4AYwBvAG0A;Sosha1_v1;7;{773484E6-F793-491D-AF92-FFDA5A20A08E};cwB1AHAAcABvAHIAdABAAHIAYQBnAG4AYQBjAG8AZABlAC4AYwBvAG0A;Sat, 04 Aug 2012 07:37:25 GMT;VABlAHMAdAAgAGUAbQBhAGkAbAA=
x-cr-puzzleid: {773484E6-F793-491D-AF92-FFDA5A20A08E}

This is a multipart message in MIME format.

------=_NextPart_000_0030_01CD7242.1A459C30
Content-Type: text/plain;
charset="us-ascii"
Content-Transfer-Encoding: 7bit

This is a test


------=_NextPart_000_0030_01CD7242.1A459C30
Content-Type: text/html;
charset="us-ascii"
Content-Transfer-Encoding: quoted-printable

<html xmlns:v=3D"urn:schemas-microsoft-com:vml" =
xmlns:o=3D"urn:schemas-microsoft-com:office:office" =
xmlns:w=3D"urn:schemas-microsoft-com:office:word" =
xmlns:m=3D"http://schemas.microsoft.com/office/2004/12/omml" =
xmlns=3D"http://www.w3.org/TR/REC-html40">

<head>
<META HTTP-EQUIV=3D"Content-Type" CONTENT=3D"text/html; =
charset=3Dus-ascii">
<meta name=3DGenerator content=3D"Microsoft Word 12 (filtered medium)">
<style>
<!--
/* Font Definitions */
@font-face
{font-family:"Cambria Math";
panose-1:0 0 0 0 0 0 0 0 0 0;}
@font-face
{font-family:Calibri;
panose-1:2 15 5 2 2 2 4 3 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
{margin:0in;
margin-bottom:.0001pt;
font-size:11.0pt;
font-family:"Calibri","sans-serif";}
a:link, span.MsoHyperlink
{mso-style-priority:99;
color:blue;
text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
{mso-style-priority:99;
color:purple;
text-decoration:underline;}
span.EmailStyle17
{mso-style-type:personal-compose;
font-family:"Calibri","sans-serif";
color:windowtext;}
.MsoChpDefault
{mso-style-type:export-only;}
@page Section1
{size:8.5in 11.0in;
margin:1.0in 1.0in 1.0in 1.0in;}
div.Section1
{page:Section1;}
-->
</style>
<!--[if gte mso 9]><xml>
<o:shapedefaults v:ext=3D"edit" spidmax=3D"1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext=3D"edit">
  <o:idmap v:ext=3D"edit" data=3D"1" />
</o:shapelayo

ut></xml><![endif]-->
</head>

<body lang=3DEN-US link=3Dblue vlink=3Dpurple>

<div class=3DSection1>

<p class=3DMsoNormal>This is a test<o:p></o:p></p>

</div>

</body>

</html>

------=_NextPart_000_0030_01CD7242.1A459C30--
Sat, 08/04/2012 - 08:14
andreychek

Howdy,

Hmm, I don't see any obvious issues in the above.

I believe Gmail started tagging emails with some information about why they were put into the spam folder... do you see anything like that if you look at this message in your spam folder?

Also, you could always try going to a site such as this one to see if you're on an RBL:

http://www.anti-abuse.org/multi-rbl-check/

-Eric

Mon, 08/06/2012 - 11:30 (Reply to #2)
compfellows

Hello, Well, my host is not in any blacklist...

Sun, 08/05/2012 - 08:00
matimont

See if you can enable DKIM (Email Messages-->DomainKeys Identified Mail and put that into the TXT record of your domain/s, at least that worked for me.

Mon, 08/06/2012 - 11:33 (Reply to #4)
compfellows

Hello, I have enabled DKIM for my domain. Its added to the DNS record now. I will wait for a while and check whether the emails go to spam in gmail or not. Thanks for the suggestion though :)

Tue, 08/07/2012 - 07:18 (Reply to #5)
compfellows

Hey, This helped! Problem Solved! Thanks matimont!

Tue, 08/07/2012 - 09:33
matimont

I'm glad you solved it!

Tue, 11/06/2012 - 14:17
KenChristopher
KenChristopher's picture

When I try Email Messages -> DomainKeys Identified Mail I get the message "DomainKeys indentified mail is not available on this system" and an offer for Virtualmin to auto install. When I click the install button I get these errors:

Installing the DKIM filter package ..

Installing package(s) with command yum -y install dkim-milter ..

Loaded plugins: fastestmirror, priorities, refresh-packagekit, security Loading mirror speeds from cached hostfile * base: yum.singlehop.com * extras: centosmirror.quintex.com * updates: mirror.steadfast.net http://software.virtualmin.com/bleed/rhel/6/i386/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404" Trying other mirror. Error: Cannot retrieve repository metadata (repomd.xml) for repository: virtualmin-bleed. Please verify its path and try again

.. install failed!

.. installation failed!

I tried finding a virtualmin bleed for CentOS 6 but cannot find one.

Is there a way I can get DKIM without virtualmin bleed or do I need to try something else?

Thanks, Ken

Tue, 06/26/2018 - 11:04
awpt.eu

Guys do you mean this screen? https://image.ibb.co/epkVkT/Schermata_2018_06_26_alle_18_03_28.png

Any one can guide us to do it in the right way?

Tue, 06/26/2018 - 11:10
awpt.eu

Was so easy evertyhing is fine thanks.

Sat, 07/27/2019 - 17:59
NadimD
NadimD's picture

Does this work only when BIND is enabled ? I tried VirtualMin's DKIM and I get that no virtual server is configured to DNS and Email. Maybe because I use my host's DNS ? Thanks!

Best Regards