whmcs error

3 posts / 0 new
Last post
#1 Mon, 05/19/2014 - 11:25
olliedog

whmcs error

Hi, having trouble with getting WHMCS to work correctly with Virtualmin/webmin.

WHMCS can create the hosting accounts no problem. WHMCS can register a domain without hosting no problem. But when i try to provision hosting and register a domain together, the hosting is provisioned and the domain is not registered.

WHMCS tech guys have been looking at this and they think it has something to do with the way the server is being restarted

extract from email

I observe that you are provision hosting account son the same server as WHMCS ins installed. So this behaviour suggests that the server is being restarted or becoming unavailable when the hosting account is provisioned. This caused the WHMCS process to be stopped, so after provisioning the hosting it is unable to go on and register the domain.

To resolve this I recommend adjusting your server settings to ensure a graceful restart is performed when an account is provisioned as opposed to a forced restart.

How do I change the way this works to make sure the domains register ok?

thanks

Andy

Mon, 05/19/2014 - 13:38
andreychek

Howdy,

If you look in Webmin -> Servers -> Apache -> Module Config -> System Configuration, what is "Command to apply configuration" set to?

If it's not set to "/usr/sbin/apache2ctl graceful", I'm curious if using that resolves the issue you're seeing.

-Eric

Mon, 05/19/2014 - 13:50 (Reply to #2)
olliedog

Hi Eric It says /etc/rc.d/init.d/httpd graceful

Does this nene to be changed to what you posted?

Andy