Per-IP Dovecot SSL Certifcates not working

3 posts / 0 new
Last post
#1 Tue, 09/30/2014 - 03:59
snoopy74

Per-IP Dovecot SSL Certifcates not working

Hello.

thank you for one of your last updates with this functionality:

Dovecot and Postfix SSL certificates If Postfix and Dovecot are setup to use SSL, they will be configured to use the certificate belonging to virtual servers with their own private IP address for connections to that IP.

Per-IP Dovecot SSL Certifcates If Dovecot version 2 or higher has SSL enabled, the certificate for domains with a private IP address will be used for connections to the Dovecot server.

That are the function i've been wainting for ! ;o)

But ... .. they are not working on my server (debian 7, virtualmin 4.11.gpl GPL)

I have a default IP for the server and four additional IPs.

The other IPs also have their SSL certificates and I copied the SSL certificates from my main-domain / main IP to dovecot and postfix - months ago. So that IMAP requests are secure and there are not warnings from thunderbird etc.

On one of those additional IPs i run one (only one) domain with it's own and trusted SSL certificates. In apache everything is working fine; the domain is SSL encoded. But connection with IMAP over SSL to that domain, i got the typical SSL warning, that the certificate is not matching the domain name. I checked that (viewed the offered certificate in thunderbird) and it's right: The SSL certificate from the main domain is shown.

So, how can i use that new function ?

Kind regards & thanks a lot for your software, Snoop

Wed, 11/19/2014 - 12:54
HarryZink

Same question here.