Restoration of virtual servers fails - gunzip failure

13 posts / 0 new
Last post
#1 Thu, 03/05/2015 - 09:36
thesmahesh

Restoration of virtual servers fails - gunzip failure

Dear Team,

Suddenly i face problem in restoring the virtualmin backups of my virtual servers. I have restored more than 50 virtual servers and these failures have started coming. I have tried restoring other virtual servers also but the problem persists. Please help. Thanks and Regards

System Information

Webmin version 1.730 Kernel and CPU Linux 3.2.0-4-amd64 on x86_64 Operating system Debian Linux 7

Error Details

 Restoring allowed MySQL hosts ..
.. done
Re-loading MySQL database ganapathi ..
.. gunzip failed!
gzip: /tmp/.webmin/881284_20040_2_restore.cgi/mydomain.org_mysql_ganapathi: Permission denied

Applying web server configuration .. .. done .. failed! See the progress output above for the reason why.

Thu, 03/05/2015 - 10:06
andreychek

Howdy,

Does this problem occur for just this one domain, or for all domains?

Also, what is the output of this command:

ls -la /tmp/.webmin/

Lastly, which Virtualmin version is it that you're using now?

-Eric

Thu, 03/05/2015 - 10:13
thesmahesh

Hello Eric

output of this command:

# ls -la /tmp/.webmin/
total 8
drwxr-xr-x 2 root root 4096 Mar  5 17:07 .
drwxrwxrwx 5 root root 4096 Mar  5 17:06 ..

Virtualmin 4.14 gpl

Just a few hours back, i had restored more than 50 domains. This problem has started appearing all of a sudden. I tested many domain backups. the problem remains the same.

Please help.

Thanks and Regards

Thu, 03/05/2015 - 11:09
Welshman
Welshman's picture

I had this today, after a WP possible hack, I tried to restore and got that error.

After I noticed the database in question had no tables and the user for the database was not correct.

I changed the user and still got it...

Eventually, I unzipped a VM backup, uploaded the com_sql file and renamed it with an sql extention, logged into SSH and ran this command and my site came back.

mysql -u theuser -pmypwd targetdb < /home/pathtouploadeddb/public_html/uploaded.sql

Worried me a bit, pesky WP.

Chaos Reigns Within, Reflect, Repent and Reboot, Order Shall Return.

Thu, 03/05/2015 - 11:33
thesmahesh

Thanks Welshman for your workarounds.

Mine is a totally difference issue. As a part of my server migration process, i have moved virtualmin backups from my old server and am trying to restore them in a new server. I had no issues during my initial 50+ restorations. This issue started cropping up all of a sudden

I have hundreds of domains to be restored urgently. Can i have the help in getting this resolved, please ?

Thanks and Regards

Thu, 03/05/2015 - 23:21
thesmahesh

Dear All,

I have hundreds of domains to be restored urgently. Can i have the help in getting this resolved, please ?

Thanks and Regards

Thu, 03/05/2015 - 23:27 (Reply to #6)
Joe
Joe's picture

A new version will be out soon; either to roll back this change or to fix it so it actually works right. It will happen before I go to bed. I don't know exactly when, but soon.

In the meantime, I believe command line restore-domain feature will work as expected (and if you have hundreds of restores, you would definitely want to use the command line anyway...doing that in the UI would take forever!). I haven't tested it, but I've been reading the restore code, and I'm pretty sure the command line restore would miss this codepath, as long as you do not specify the "--as-owner" option.

Let me know if that's not the case.

I would recommend trying just one before doing all of your hundreds of restores.

--

Check out the forum guidelines!

Fri, 03/06/2015 - 00:28 (Reply to #7)
Joe
Joe's picture

Actually, double-checking the code, I think the problem will also occur when using the command line version (which is kinda bug-like in and of itself).

--

Check out the forum guidelines!

Fri, 03/06/2015 - 00:04
andreychek

On Debian/Ubuntu, a quick and easy way to downgrade to Virtualmin GPL 4.14 is with this command:

apt-get install webmin-virtual-server=4.14.gpl

Fri, 03/06/2015 - 00:41
Joe
Joe's picture

I'm rolling out a fixed version 4.15-2 now. It will be out in about 10-15 minutes.

--

Check out the forum guidelines!

Fri, 03/06/2015 - 03:50
Joe
Joe's picture

It should be in all of our repositories. So, updating with yum or apt-get should get the new version.

--

Check out the forum guidelines!

Fri, 03/06/2015 - 04:11
thesmahesh

Issue resolved after upgrading 4.15-2

Thanks Joe, Erci & Team

Wonderful people and Wonderful software...

Sat, 03/07/2015 - 05:24
Welshman
Welshman's picture

Yeah, thanks a lot guys, can confirm here as well, working a treat.

Chaos Reigns Within, Reflect, Repent and Reboot, Order Shall Return.

Topic locked