Php version Update Conflicts


I hope some1 else has had this problem and has a solution.

I have 2 php versions installed on my server 5.3 and 5.4.

Currently there are 5.4 php updates, but when i run the yum update, i get these errors for each module.

Error: Package: php-zts-5.3.3-40.el6_6.x86_64 (@updates) Requires: php-common(x86-64) = 5.3.3-40.el6_6 Removing: php-common-5.3.3-40.el6_6.x86_64 (@updates) php-common(x86-64) = 5.3.3-40.el6_6 Updated By: php-common-5.4.42-1.el6.remi.x86_64 (remi) php-common(x86-64) = 5.4.42-1.el6.remi Available: php-common-5.3.3-38.el6.x86_64 (base) php-common(x86-64) = 5.3.3-38.el6 Available: php-common-5.4.41-1.el6.remi.x86_64 (remi) php-common(x86-64) = 5.4.41-1.el6.remi

Is there a way to set separate updates for each version?




Howdy -- it looks like you have a PHP version from a third party repository installed. That can cause conflicts with the default CentOS PHP version.

If you're looking to use multiple PHP versions, our suggestion would be the method described in the documentation here:

What you may want to do is remove the PHP version that came from the third party repository, and replace that with the PHP version in the link above.