Ubuntu 16.04

83 posts / 0 new
Last post
#1 Sat, 04/16/2016 - 03:44
hostile

Ubuntu 16.04

Hi, please make it works under Ubuntu 16.04

Sat, 04/16/2016 - 08:29
andreychek

Howdy,

Yup! Virtualmin will support all the Ubuntu LTS releases. We'll have support for that out on or shortly after the release date.

-Eric

Sat, 04/16/2016 - 12:27
hostile

okay thats soon.

Fri, 04/22/2016 - 09:49
hostile

16.04 is out, update please :)

Fri, 04/22/2016 - 13:19
nonparity

Yes an update on this would be great. I need to order another server soon and would prefer to start with 16.04 on it. Thanks for working on adding this support guys!

Fri, 04/22/2016 - 14:16
andreychek

Howdy,

We're finalizing Ubuntu 16.04 support as we speak, it'll be out very soon!

I'd like to say it'll be out later today, but that might be pushing it... very likely this weekend though.

-Eric

Fri, 04/22/2016 - 15:28
AustinTX

@andreychek: Thank you so much! Will it be possible to easily migrate Ubuntu Linux 14.04.x systems to 16.04?

Fri, 04/22/2016 - 16:37
andreychek

Howdy,

When you say migrate -- do you mean move your domains from one server to another? Or are you referring to upgrading a given server to a new distro?

You'll be able to do both, though each comes with their own benefits and drawbacks. Migration instructions, along with upgrade instructions of previous distros, are available here (upgrade instructions for 16.04 are on their way):

https://www.virtualmin.com/documentation/system/upgrades-and-migrations

Fri, 04/22/2016 - 17:48
AustinTX

@andreychek: Yes, I want to try upgrading Ubuntu 14.04.x in place to the 16.04 distro. I'll wait til you post a tutorial!

Sun, 04/24/2016 - 05:24
Vinz98

Hi there, yesterday installed 16.04 on new vps. After that I ran the classic install lines and got errors. Question is: When the right 16.04 install package will ne released, do I need to take action in deleting things on the server or do I simply rerun the classic lines and install? Or will it be best to rerun the fresh ubuntu installation again? And install on a clean system?

Sun, 04/24/2016 - 08:03 (Reply to #10)
andreychek

Once Virtualmin support for Ubuntu 16.04 is release, it should be no problem to re-run the installer on your server. Though note that you'll want to re-download the installer to get the latest version of it.

We're working hard on support for it over the weekend, and it's almost ready -- some of those changes included changes to the install.sh file.

-Eric

Sun, 04/24/2016 - 13:31 (Reply to #11)
Vinz98

Thanks for your answer. I already deleted the local install package. I want to thank you guys for the great work and the great product.

Sun, 04/24/2016 - 09:59
lazside

Also wating to support 16.04, wil is be ready today ? I am a little impatient :)

Sun, 04/24/2016 - 10:38
fgossart

I have to change my server and transfer all my websites before end of current month. So I'd lilek to pur ubuntu 16.04 and get time to put some corrections to the web sites for PHP7. But if not released in one or two days, I will have to go back to ubuntu 14.04 and PHP5.

Sun, 04/24/2016 - 13:45
andreychek

It's almost ready, we'll be making an announcement soon!

Sun, 04/24/2016 - 15:41
andreychek

This all ended up taking slightly longer than I had hoped. I didn't think we were going to need a new Virtualmin release to support it, we had things working properly a few weeks ago. But it looks like some changes occurred since that time that require an update within Virtualmin itself.

Which is no problem, it just takes a tad longer.

We're in the process of preparing a new release now that corrects those issues.

If all goes well and we don't discover any showstopping issues, that will go out tonight.

That all works out though, as there were a few outstanding Virtualmin bugs (unrelated to this new Ubuntu release) that I was really eager to see fixed :-)

Note that I don't have upgrade instructions written up yet. Since this took a little longer than expected I didn't end up with time to handle that. But those will be here soon too (that said, note that Ubuntu recommends not performing upgrades until 16.04.1 comes along in a few months).

-Eric

Sun, 04/24/2016 - 21:03
Arvi89

Awesome, I didn't expect a release that early working with Ubuntu 16.04 :)

Sun, 04/24/2016 - 21:18
hostile

Bring it up boy :D

Sun, 04/24/2016 - 23:36
andreychek

Sorry guys, it looks like some personal things got in the way and made it so we couldn't get the release finished up tonight. The code is ready it's just a matter of packaging it up and getting it into the repository.

I've apparently been wrong before as far as times and dates go, but I can't see why this won't occur on Monday :-)

-Eric

Mon, 04/25/2016 - 00:17
andreychek

Okay, just as I was about to go to bed, I was told that Virtualmin 5.02, the one needed for Ubuntu 16.04 to work, was being built and put into the repo.

We're not going to put out an official announcement tonight, but just between you and me, if you see that version in the repo -- just re-download the install.sh script (it'll be version 1.1.4), and that should be all you need in order to run Virtualmin on Ubuntu 16.04 :-)

Enjoy!

The official announcement will be going out tomorrow (Monday).

-Eric

Mon, 04/25/2016 - 00:43
andreychek

Okay, the new Virtualmin version is in place, as is the new install script.

So things should be good to go with Ubuntu 16.04 support!

Please let us know if you run into any issues. Virtualmin didn't officially support MySQL 5.7 until this release. And Ubuntu 16.04 is also the only distro to ship with PHP 7 by default, we ran into a couple of minor install script problems that were corrected.

Feel free to give that a whirl, and let us know how it works for you.

An official announcement will be coming tomorrow, and I'll also be working on upgrade instructions at that point.

-Eric

Tue, 04/26/2016 - 18:18 (Reply to #21)
trenzterra

Thanks for your help on this. Any idea when the upgrade instructions will be out? I tried an upgrade on my own but it gets stuck at the MySQL 5.7 portion. Apparently there's a 'bug' of sorts when upgrading from an old MySQL version to a new one: https://bugs.launchpad.net/ubuntu/+source/mysql-5.7/+bug/1571865

It would be great if you could cover this in the upgrade instruction :)

Meanwhile, fervently praying that my upgrade will go flawlessly. Heh.

Mon, 04/25/2016 - 05:53
Linux7

Downloaded Ver 1.1.4 of the GPL script and it appears the install failed. This is a fresh install of a Ubuntu 16.04 LTS dreamhost cloud server that was fully upgraded.

*********************
Reading package lists...
Building dependency tree...
Reading state information...
The following additional packages will be installed:
webmin-virtual-server webmin-virtual-server-theme
The following NEW packages will be installed:
virtualmin-base webmin-virtual-server webmin-virtual-server-theme
0 upgraded, 3 newly installed, 0 to remove and 13 not upgraded.
Need to get 4668 kB of archives.
After this operation, 100 kB of additional disk space will be used.
Get:1 http://software.virtualmin.com/gpl/ubuntu virtualmin-universal/main amd64 webmin-virtual-server all 5.02.gpl [2326 kB]
Get:2 http://software.virtualmin.com/gpl/ubuntu virtualmin-universal/main amd64 webmin-virtual-server-theme all 9.0-2 [2327 kB]
Err:2 http://software.virtualmin.com/gpl/ubuntu virtualmin-universal/main amd64 webmin-virtual-server-theme all 9.0-2
Hash Sum mismatch
Get:3 http://software.virtualmin.com/gpl/ubuntu virtualmin-xenial/main amd64 virtualmin-base all 1.0-35 [14.1 kB]
Fetched 4668 kB in 0s (6369 kB/s)
WARN - 2016-04-25 06:10:24 - apt-get seems to have failed. Are you sure your OS and version is supported?
WARN - 2016-04-25 06:10:24 - http://www.virtualmin.com/os-support
FATAL - 2016-04-25 06:10:24 - Fatal Error Occurred: Installation failed: 0
FATAL - 2016-04-25 06:10:24 - Cannot continue installation.
FATAL - 2016-04-25 06:10:24 - Attempting to remove virtualmin repository configuration, so the installation can be
FATAL - 2016-04-25 06:10:24 - re-attempted after any problems have been resolved.
FATAL - 2016-04-25 06:10:24 - Removing temporary directory and files.
FATAL - 2016-04-25 06:10:24 - If you are unsure of what went wrong, you may wish to review the log
FATAL - 2016-04-25 06:10:24 - in /root/virtualmin-install.log
*********************

Contents of these files:
/etc/issue: "Ubuntu 16.04 LTS \n \l"
/etc/issue.net: "Ubuntu 16.04 LTS"

cat /etc/lsb-release:
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=16.04
DISTRIB_CODENAME=xenial
DISTRIB_DESCRIPTION="Ubuntu 16.04 LTS"

EDIT-1:
INFO - /usr/bin/apt-get --config-file apt.conf.noninteractive -y --force-yes install virtualmin-base
...in progress, please wait...
..W: --force-yes is deprecated, use one of the options starting with --allow instead.
E: Failed to fetch http://software.virtualmin.com/gpl/ubuntu/dists/virtualmin-universal/mai... Hash Sum mismatch

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

/usr/bin/apt-get --config-file apt.conf.noninteractive -y --force-yes install virtualmin-base failed. Error (if any): 0

Displaying the last 15 lines of /root/virtualmin-install.log to help troubleshoot this problem:

EDIT-2:
Now when I run apt-get upgrade I get this:

apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
byobu isc-dhcp-client librados2 librbd1 linux-headers-generic linux-headers-virtual linux-image-virtual linux-virtual lvm2 qemu-block-extra qemu-utils
0 upgraded, 0 newly installed, 0 to remove and 11 not upgraded.

Mon, 04/25/2016 - 04:20
Arvi89

It worked for me, just had to edit /etc/issue (but it's always the case with this server), and also, the webalizer conf file was not in /etc/webalizer.conf but /etc/webalizer/webalizer.conf

And now it works perfectly, thx guys! :) (Good thing we have the old them first too so it runs the wizard)

edit: but I can't install roundcube, it says it requires PHP5 (I think it works with PHP7 now), and same for phpmyadmin.

edit2: even after installing php 5.6 with ppa/onderj, and I've changed php 7 to php 5.6 in php configuration, I still can't install roundcube or phpmyadmin, it still says that it requires php 5.

edit3: ok, even if I set PHP version to 5.6 to a virtual server, it still uses php 7 (checked from phpversion()).

Mon, 04/25/2016 - 04:09
fgossart

No issue with installer Webalizer conf has to be tuned but running my Joomla 3.5.1 websites in error_logs : mod_fcgid: stderr: PHP Warning: session_write_close(): Failed to write session data (user). Please verify that the current setting of session.save_path is correct

and display Mysql connect error Error displaying the error page: Application Instantiation Error: Could not connect to MySQL.

so actually not possible to use

Mon, 04/25/2016 - 06:08
Vinz98

Install went flawless now. Many thanks again for the professional work! I am up and running.

Mon, 04/25/2016 - 07:52
andreychek

Howdy,

Thanks to everyone for trying it out, and letting us know the issues you're seeing!

It looks like we goofed, and forget that the webalizer issue (which we fixed) we actually fixed in Webmin, not Virtualmin. So we should have released a new Webmin version too. Nuts! The workaround in the meantime is to run this command:

ln -s /etc/webalizer/webalizer.conf /etc/webalizer.conf

As far as the RoundCube Install Script goes -- I'm going to ask Jamie about that, we saw a similar problem in another script that we corrected. Apparently we didn't get them all. We'll get the scripts corrected so that they install properly, but as soon as I figure out what the problem is I'll post a patch or workaround that can be used to get those installed.

-Eric

Mon, 04/25/2016 - 08:09 (Reply to #27)
hostile

thank you installing it as we speak :)

Mon, 04/25/2016 - 08:33
Arvi89

Great :)

Also after installing php 5.6 with the ondrej ppa, even if it's in the list, and I select php version 5.6, it uses php 7.

Mon, 04/25/2016 - 20:02
hostile

yeh it need bit of a touch and would be perfect :)

Tue, 04/26/2016 - 01:28
andreychek

I just wanted to let everyone know that we're working hard to sort out what's going on with all that... we fixed what we thought was the problem, only to run into some issues we didn't realize were going on.

We'll have all that sorted out here soon though!

-Eric

Tue, 04/26/2016 - 05:11
rondu

virtualmin installation failed

here is last part log message " INFO - Succeeded. INFO - Installing Virtualmin and all related packages now using the command: INFO - /usr/bin/apt-get --config-file apt.conf.noninteractive -y --force-yes install virtualmin-base ...in progress, please wait... ....W: --force-yes is deprecated, use one of the options starting with --allow instead. E: Failed to fetch http://software.virtualmin.com/gpl/ubuntu/dists/virtualmin-universal/mai... Hash Sum mismatch

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

/usr/bin/apt-get --config-file apt.conf.noninteractive -y --force-yes install virtualmin-base failed. Error (if any): 0

Displaying the last 15 lines of /root/virtualmin-install.log to help troubleshoot this problem: Building dependency tree... Reading state information... The following additional packages will be installed: webmin-virtual-server webmin-virtual-server-theme The following NEW packages will be installed: virtualmin-base webmin-virtual-server webmin-virtual-server-theme 0 upgraded, 3 newly installed, 0 to remove and 0 not upgraded. Need to get 4668 kB of archives. After this operation, 100 kB of additional disk space will be used. Get:1 http://software.virtualmin.com/gpl/ubuntu virtualmin-universal/main amd64 webmin-virtual-server all 5.02.gpl [2326 kB] Get:2 http://software.virtualmin.com/gpl/ubuntu virtualmin-universal/main amd64 webmin-virtual-server-theme all 9.0-2 [2327 kB] Err:2 http://software.virtualmin.com/gpl/ubuntu virtualmin-universal/main amd64 webmin-virtual-server-theme all 9.0-2 Hash Sum mismatch Get:3 http://software.virtualmin.com/gpl/ubuntu virtualmin-xenial/main amd64 virtualmin-base all 1.0-35 [14.1 kB] Fetched 4668 kB in 2s (1828 kB/s) WARN - apt-get seems to have failed. Are you sure your OS and version is supported? WARN - http://www.virtualmin.com/os-support

FATAL - Fatal Error Occurred: Installation failed: 0 FATAL - Cannot continue installation. FATAL - Attempting to remove virtualmin repository configuration, so the installation can be FATAL - re-attempted after any problems have been resolved. FATAL - Removing temporary directory and files. FATAL - If you are unsure of what went wrong, you may wish to review the log FATAL - in /root/virtualmin-install.log "

Tue, 04/26/2016 - 08:47 (Reply to #32)
hostile

thats something with ur server cuz it installs okay

Tue, 04/26/2016 - 13:01 (Reply to #33)
andreychek

Someone above mentioned that they had received that error during an installation attempt. If I understood correctly, what they do is run "apt-get update" and "apt-get upgrade"... and after doing that I believe they were able to complete the installation.

Could you see what happens if you try running those two commands?

-Eric

Tue, 04/26/2016 - 16:14
doofusdavid

So, I've tried this three different ways.

  1. 16.04 server downloaded iso in VirtualBox (works)
  2. Vagrant ubuntu/xenial64 package (breaks)
  3. AWS ubuntu 16.04 (breaks)

The last two break very similarly:

Building dependency tree...
Reading state information...
The following additional packages will be installed:
  webmin-virtual-server webmin-virtual-server-theme
The following NEW packages will be installed:
  virtualmin-base webmin-virtual-server webmin-virtual-server-theme
0 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
Need to get 4668 kB of archives.
After this operation, 100 kB of additional disk space will be used.
Get:1 http://software.virtualmin.com/gpl/ubuntu virtualmin-universal/main amd64 webmin-virtual-server all 5.02.gpl [2326 kB]
Get:2 http://software.virtualmin.com/gpl/ubuntu virtualmin-universal/main amd64 webmin-virtual-server-theme all 9.0-2 [2327 kB]
Err:2 http://software.virtualmin.com/gpl/ubuntu virtualmin-universal/main amd64 webmin-virtual-server-theme all 9.0-2
  Hash Sum mismatch
Get:3 http://software.virtualmin.com/gpl/ubuntu virtualmin-xenial/main amd64 virtualmin-base all 1.0-35 [14.1 kB]
Fetched 4668 kB in 1s (3073 kB/s)
WARN - apt-get seems to have failed. Are you sure your OS and version is supported?
WARN - http://www.virtualmin.com/os-support

FATAL - Fatal Error Occurred: Installation failed: 0
FATAL - Cannot continue installation.
FATAL - Attempting to remove virtualmin repository configuration, so the installation can be
FATAL - re-attempted after any problems have been resolved.
FATAL - Removing temporary directory and files.
FATAL - If you are unsure of what went wrong, you may wish to review the log
FATAL - in /root/virtualmin-install.log

It looks to be an error in the hash for webmin-virtual-server-theme which breaks. I've done an apt-get update and upgrade afterwards, but upgrade finds nothing.

Thanks for your work on this!

Tue, 04/26/2016 - 17:14
andreychek

Howdy,

Those who are seeing that hash mismatch problem -- are you all using Virtualmin GPL with a 64 bit OS?

-Eric

Tue, 04/26/2016 - 17:24 (Reply to #36)
doofusdavid

for me, the one that worked was xenial-server-amd64.iso downloaded from ubuntu.

The two that failed were ubuntu/xenial64 for vagrant (here) and the amd64 version of xenial for AWS (here)

Tue, 04/26/2016 - 18:18 (Reply to #37)
andreychek

Are you using Virtualmin Pro or GPL on your server there? Thanks!

-Eric

Tue, 04/26/2016 - 18:34 (Reply to #38)
Linux7

Yes, Virtualmin GPL and a 64-bit OS. Tried numerous installs and still get a failure each time...

Tue, 04/26/2016 - 20:16
andreychek

That's all very odd! I'm struggling to reproduce that issue, even though I'm also testing with 64 bit Virtualmin GPL.

And there's a number of folks who were able to install on that platform.

But there's also multiple reports of this hashsum issue.

Could I perhaps log into someone's system who's experiencing this problem?

If you're receiving a hash sum mismatch when performing an install, and you wouldn't mind me logging in to take a look, can you email me login credentials at eric@virtualmin.com? You can email me a password if you want, or just add my SSH key at the bottom to an account with admin permissions.

If you could, make the subject something like "Ubuntu hash sum problem" to help me keep track of who's emailing me :-)

Thanks!

-Eric

SSH key is below:

ssh-rsa AAAAB3NzaC1yc2EAAAABIwAAAQEA0xsh0K9ZFzSV5JpdZ16OnwVg0uNVbebW6vBnZ8T+UYKpvLac0xx5QQRPdyBWO9dahFrFwbKbMFjZ+01RfbBi0SpJesL4LN9H7sqKYnatqFTVQek0IvJqHicHcySOjWjZMEX1ovc63cYIXEYNoS3CVMcYhWMFhig1ANuUQwoG7fFcjy2It9XeaP+AmIb7LvUEZr5zqeUV03sXoV2CmtpkpbQ8Gn5KyyNKjI/AwZpAZdkkJLCvvhKZz15W8bdK27Q89HW3g6IGwS604p8aLGszYH6e9eAfFzZ8hVa6hHEe7cJE6I14GhDiByYwNsLblv9A+zb/HdO19Miokj9kTgemew== eric@virtualmin.com
Tue, 04/26/2016 - 20:38
SeeBenClick

This is a reminder to try out on a server that you do not depend on for your income first. I'm sure the seasoned pros already know this but other programs you depend on may not be Ubuntu 16 ready, like your favorite backup tool. Speaking of which, is there already a thread about the best method of live backup and bare metal restoration for an entire system with Virtualmin and Ubuntu 16?

Tue, 04/26/2016 - 23:13
andreychek

Install Script Fix

Just a heads up that Jamie thinks he resolved the Install Script issue... would anyone care to test? This is a patch for the file "/usr/share/webmin/virtual-server/script_form.cgi" -- the first line of code is at line 41 (it's a patch, so remove lines beginning with a -, and add lines beginning with a +):

if (defined(&$phpvfunc)) {
  @vers = &$phpvfunc($d, $ver);
  @gotvers = grep { local $v = $_; local $_;
-   &check_php_version($d, $v) } @vers;
+   &check_php_version($d, $v) }
+ &expand_php_versions($d, \@vers);
  @gotvers = sort { &get_php_version($b, $d) <=>
-                          &get_php_version($a, $d) }
- &expand_php_versions($d, \@gotvers);
+                          &get_php_version($a, $d) } @gotvers;
  if (!@gotvers) {
  print &text('scripts_ephpvers', join(" or ", @vers)),"<p>\n";
  $ok = 0;

After applying the above, restart Webmin with "service webmin restart".

We'll be releasing a new minor release soon to address this and other issues.

-Eric

Sat, 04/30/2016 - 22:40 (Reply to #42)
hostile

can someone share patched /usr/share/webmin/virtual-server/script_form.cgi

i cant get it working

thanks

Wed, 04/27/2016 - 01:52
hostile

For me works on cloud server I Install from thier panel 14.04 Ubuntu and Upgrade to 16.04

sudo apt-get update
sudo apt-get -y upgrade
sudo apt-get -y dist-upgrade
reboot
sudo apt-get -y install update-manager-core
sudo do-release-upgrade

If Ubuntu 16.04 has not been released yet, you should see the following:

Checking for a new Ubuntu release
No new release found

sudo do-release-upgrade -d

Keep configs when it asks

Then virtualmin and works fine

Wed, 04/27/2016 - 03:50
Arvi89

I could install the roundcube properly, the patch worked :) I had an error with roundcube after that, but might be because of some tests, I'll re-install and check.

Wed, 04/27/2016 - 05:43
rondu

Thank you Eric ,

In digitalocean and one of my bare metal server it worked fine . I did not tried in EC2 yet But in scaleway that specific issues occurs ( mismtch hash ) . it seems all component install but virtualmin theme seems does not install ( virtual server directory is missing so patch is not solution is this case

In previous reply you wanted to access , In that case How can i send you access to that server ?

Wed, 04/27/2016 - 10:55
trenzterra

Hi there,

Having issues with a brand new droplet running 16.04 LTS x64, 512MB RAM 20GB HDD.

It gets stuck here everytime:

INFO - /usr/bin/apt-get --config-file apt.conf.noninteractive -y --force-yes install bsdutils postfix postfix-pcre webmin usermin ruby libxml-simple-perl libcrypt-ssleay-perl unzip zip libfcgi-dev bind9 spamassassin spamc procmail procmail-wrapper libnet-ssleay-perl libpg-perl libdbd-pg-perl libdbd-mysql-perl quota iptables openssl python mailman subversion ruby irb rdoc ri mysql-server mysql-client mysql-common postgresql postgresql-client awstats webalizer dovecot-common dovecot-imapd dovecot-pop3d proftpd libcrypt-ssleay-perl awstats clamav-base clamav-daemon clamav clamav-freshclam clamav-docs clamav-testfiles libapache2-mod-fcgid apache2-suexec-custom scponly apache2 apache2-doc libapache2-svn libsasl2-2 libsasl2-modules sasl2-bin php-pear php php-cgi libapache2-mod-php php-mysql: Succeeded. INFO - Succeeded. INFO - Installing Virtualmin and all related packages now using the command: INFO - /usr/bin/apt-get --config-file apt.conf.noninteractive -y --force-yes install virtualmin-base ...in progress, please wait... ................................................

I have tried reprovisioning the droplet and running the install again, but it hangs at the exact same place. Thereafter my droplet becomes unresponsive and I have to force reboot it. I must add that I did apt-get update and apt-get upgrade on the new 16.04 LTS before installing Virtualmin.

The installation on a similar 16.04 droplet yesterday went well though. Did anything change between then and now?

Many thanks.

Wed, 04/27/2016 - 12:13
Arvi89

Ok, so roundcube 1.1.5 doesn't with PHP 7, but apparently 1.2-beta does (cf https://forum.directadmin.com/showthread.php?t=52368), so event if it's beta, I guess it should be set in the list, otherwise limit to php 5 (and make sure that if php 5 is installed and set in php version, it takes php 5 and not php 7, like it did for me).

edit: Apparently even a rc is available.

Wed, 04/27/2016 - 14:07
andreychek

Hash Sum Issue Workaround

Okay, after poking at this for awhile, I do think I finally determine the source of the issue. There really is a metadata checksum error in the 64 bit version of one of the packages, and all versions of Ubuntu 16.04 are seeing that issue. The 32 bit version is fine.

So why does it work for some people on 64 bit Linux? There appears to be an apt setting enabled by default, that is causing apt to fall back to 32 bit packages if the 64 bit package fails to install.

In Amazon/EC2, that option has been disabled, and that's why things aren't working there. It

Now, Joe is looking into this issue... if you listen carefully you might hear him screaming at apt... it's apparently been a difficult issue to track down :-)

While he's busy yelling at apt, here's a workaround --

Just create a new file (or edit an existing file) in "/etc/apt/apt.conf.d/", and add this one line:

APT::Architectures:: "i386";

After setting that, the install should finish successfully.

Again, we are working on the issue, the above is just a workaround until we've sorted out why it's not setting the checksum properly.

-Eric

Wed, 04/27/2016 - 14:13 (Reply to #49)
andreychek

Shoot, just after I typed up the above, Joe appears to have gotten it working.

We'll need to submit this question to MythBusters, whether yelling at a problem aids in getting it resolved quickly :-)

Can you guys give it a try again? (without the above mentioned workaround)

Wed, 04/27/2016 - 18:44 (Reply to #50)
trenzterra

Hi, I don't know if my isuse is related to the above, but I am still having the following problem on a DigitalOcean droplet that I didn't have two days ago. Any help would be greatly appreciated!

Hi there, Having issues with a brand new droplet running 16.04 LTS x64, 512MB RAM 20GB HDD. It gets stuck here everytime: INFO - /usr/bin/apt-get --config-file apt.conf.noninteractive -y --force-yes install bsdutils postfix postfix-pcre webmin usermin ruby libxml-simple-perl libcrypt-ssleay-perl unzip zip libfcgi-dev bind9 spamassassin spamc procmail procmail-wrapper libnet-ssleay-perl libpg-perl libdbd-pg-perl libdbd-mysql-perl quota iptables openssl python mailman subversion ruby irb rdoc ri mysql-server mysql-client mysql-common postgresql postgresql-client awstats webalizer dovecot-common dovecot-imapd dovecot-pop3d proftpd libcrypt-ssleay-perl awstats clamav-base clamav-daemon clamav clamav-freshclam clamav-docs clamav-testfiles libapache2-mod-fcgid apache2-suexec-custom scponly apache2 apache2-doc libapache2-svn libsasl2-2 libsasl2-modules sasl2-bin php-pear php php-cgi libapache2-mod-php php-mysql: Succeeded. INFO - Succeeded. INFO - Installing Virtualmin and all related packages now using the command: INFO - /usr/bin/apt-get --config-file apt.conf.noninteractive -y --force-yes install virtualmin-base ...in progress, please wait... ................................................ I have tried reprovisioning the droplet and running the install again, but it hangs at the exact same place. Thereafter my droplet becomes unresponsive and I have to force reboot it. I must add that I did apt-get update and apt-get upgrade on the new 16.04 LTS before installing Virtualmin. The installation on a similar 16.04 droplet yesterday went well though. Did anything change between then and now? Many thanks.

The virtualmin install log stops here:

INFO - 2016-04-27 19:20:54 - Started installation log in /root/virtualmin-install.log DEBUG - 2016-04-27 19:20:54 - Install mode: full DEBUG - 2016-04-27 19:20:54 - Product: Virtualmin GPL DEBUG - 2016-04-27 19:20:54 - Virtualmin Meta-Package list: virtualmin-base DEBUG - 2016-04-27 19:20:54 - install.sh version: 1.1.4 INFO - 2016-04-27 19:20:54 - Checking for fully qualified hostname... INFO - 2016-04-27 19:20:54 - Hostname OK: fully qualified as buyfromwhere.com INFO - 2016-04-27 19:20:54 - Installing serial number and license key into /etc/virtualmin-license INFO - 2016-04-27 19:20:54 - Loading OS selection library... INFO - 2016-04-27 19:20:55 - Download of http://software.virtualmin.com/lib/oschooser.pl Succeeded. INFO - 2016-04-27 19:20:55 - Loading OS list... INFO - 2016-04-27 19:20:55 - Download of http://software.virtualmin.com/lib/os_list.txt Succeeded. INFO - 2016-04-27 19:20:55 - Operating system name: Ubuntu Linux INFO - 2016-04-27 19:20:56 - Operating system version: 16.04 INFO - 2016-04-27 19:20:56 - Configuring package manager for Ubuntu Linux 16.04... INFO - 2016-04-27 19:20:56 - Enabling universe repositories, if not already available... INFO - 2016-04-27 19:20:56 - Disabling cdrom repositories... INFO - 2016-04-27 19:21:03 - Cleaning up apt headers and packages, so we can start fresh... INFO - 2016-04-27 19:21:03 -

Pages

Topic locked