[BUG? ]Cannot add sql user on one single sub domain

5 posts / 0 new
Last post
#1 Mon, 06/27/2016 - 21:26
pixelpadre

[BUG? ]Cannot add sql user on one single sub domain

Too weird. I can add all kinds of subdomains all with a sql user name.....except for one single solitary domain. I have deleted and redeleted all to no avail.

I have uploaded the tables to the database.

But when I try to add a user it will not give me a sql user name for the database associated with the domain..Very frustrating.

I have used the virtualmin delete disable to delete the domain many times. FTP confirms each time that all of the directory/files are deleted.

I have added a test sub domain bogus.com and added user and got a lovely sql username.

Any ideas?

Mon, 06/27/2016 - 22:24
andreychek

Howdy,

Hmm, I'm not entirely certain I follow... what problem is it that you're having exactly when trying to add a database user?

-Eric

Tue, 06/28/2016 - 09:51 (Reply to #2)
pixelpadre

I am trying to get the new user to have a mysql user name in addition to imap pop ftp name. I can do it with any other domain. But for just that one domain, it refuses to issue me a mysql user name.

Not a big deal...I can use a different user account to create the database.

I can give you the login info. You will have to see it for yourself. There simply is no way to create mysql for this one single domain. Somewhere along the line of deleting and creating, a switch was set that said no dbase access, regardless of what radio buttons and database files are authorized for the user during the create process.

I have a dozen websites and I can create mysql users on any of those domains. There is just one that I can not.

Tue, 06/28/2016 - 10:58
pixelpadre

OK looks like it might be a bug. I can replicate the problem,

When I created the virtual server the first time, I didnt have create database checked in the box. Reason...I wanted to create my own databases later.

So now the virtualserver is active with no way to add a database. So, I delete the virtual server using delete/disable.

Then I go and create the same virtual server again, this time with database enabled in the check box.

Great, I can now add databases. However, when I attempt to add user, a user will be created without sql credential.

Simple.

This is a bummer because I created a whole bunch of virtual servers without databases, for the reason stated above. Now I can not add sql user to any of those servers.

:(

Sun, 07/10/2016 - 09:47
pixelpadre

No one acknowledging this yet?