502 Bad Getaway Error on Virtualmin Nginx server

2 posts / 0 new
Last post
#1 Wed, 08/17/2016 - 09:59
Freddy63
Freddy63's picture

502 Bad Getaway Error on Virtualmin Nginx server

Hello,

I have Virtualmin 5.04 GPL installed and everything works fine until a reboot. I get a 502 Bad Getaway error after the reboot. I've installed Virtualmin with Nginx using following tutorial, https://tjosm.com/3801/setting-virtualmin-control-panel-nginx/

It worked well until today. I tried installing on Ubuntu 14.04 x64 server and a CentOS 7.2 x64 bit server. Both had 1GB ram. Both DigitalOcean servers. I see following entries on Nginx error log.

2016/08/17 14:29:00 [error] 1601#0: *1 connect() to unix:/var/php-nginx/14714438902273.sock/socket failed (111: Connection refused) while connecting to upstream, client: 123.231.125.139, server: domain.com, request: "GET / HTTP/1.1", upstream: "fastcgi://unix:/var/php-nginx/14714438902273.sock/socket:", host: "domain.com"
2016/08/17 14:35:52 [error] 1601#0: *5 connect() to unix:/var/php-nginx/14714438902273.sock/socket failed (111: Connection refused) while connecting to upstream, client: 93.174.93.218, server: domain.com, request: "GET http://httpheader.net/ HTTP/1.1", upstream: "fastcgi://unix:/var/php-nginx/14714438902273.sock/socket:", host: "httpheader.net"

It's working until a reboot. I tried creating another virtual server after the reboot with another domain. It worked until next reboot. I don't now what's happening. Please help me fix this.

Thanks in advance!

Fri, 09/02/2016 - 21:41
Freddy63
Freddy63's picture

This is a bug in Webmin 1.810 and reported here. And there's a Temporary Workaround on Ubuntu until it's been fixed.