INstall Error on Fedora Core 3

16 posts / 0 new
Last post
#1 Tue, 10/11/2005 - 17:41
FaisalMehmood

INstall Error on Fedora Core 3

Installed on a new clean install of FC 3. Just got the server and ran the installer ... didnt work :(

(6/23): wbt-virtualmin-nu 100% |=========================| 1.8 MB 00:03 (7/23): wbt-virtualmin-nu 100% |=========================| 1.9 MB 00:03 (8/23): wbm-virtualmin-ht 100% |=========================| 7.9 kB 00:00 (9/23): wbt-virtualmin-nu 100% |=========================| 1.9 MB 00:03 (10/23): wbt-virtualmin-n 100% |=========================| 1.9 MB 00:03 (11/23): awstats-6.5-0.1. 100% |=========================| 1.0 MB 00:01 (12/23): ust-virtualmin-n 100% |=========================| 286 kB 00:00 (13/23): wbm-virtualmin-s 100% |=========================| 20 kB 00:00 (14/23): usermin-1.160-1. 100% |=========================| 2.8 MB 00:04 (15/23): webmin-1.230-1.n 100% |=========================| 9.1 MB 00:11 (16/23): proftpd-1.2.10-9 100% |=========================| 676 kB 00:01 (17/23): virtualmin-base- 100% |=========================| 11 kB 00:00 (18/23): wbm-virtualmin-m 100% |=========================| 18 kB 00:00 (19/23): httpd-2.0.53-3.2 100% |=========================| 892 kB 00:02 (20/23): wbm-virtualmin-d 100% |=========================| 10 kB 00:00 (21/23): apr-0.9.4-24.2.i 100% |=========================| 87 kB 00:00 (22/23): wbt-virtualmin-n 100% |=========================| 1.9 MB 00:03 (23/23): wbm-virtualmin-a 100% |=========================| 21 kB 00:00 unsigned package virtualmin-base-1.0-14.noarch.rpm Installation failed: 1 Removing virtualmin-release package, so that installation can be re-attempted after any problems reported are resolved.

Tue, 10/11/2005 - 18:03
Joe
Joe's picture

Oops. My fault, as I forgot to sign the latest package version. Fixed now. Sorry for the inconvenience!

--

Check out the forum guidelines!

Tue, 10/11/2005 - 18:04
Joe
Joe's picture

I should also mention their have been some changes in that latest package, and I'd welcome feedback on any problems you might have.

--

Check out the forum guidelines!

Tue, 10/11/2005 - 18:10
FaisalMehmood

Still having the Same Problem. Did a rpm -e virtualmin-release

Do i need to re-download the installer install.sh ?

Tue, 10/11/2005 - 21:46
FaisalMehmood

Same problem ??? What gives ?

Install: wbm-virtualmin-mailman.noarch 0:2.80-1 - virtualmin-universal
Install: wbm-virtualmin-svn.noarch 0:2.80-1 - virtualmin-universal
Install: wbt-virtualmin-nuvola.noarch 0:1.226-1 - virtualmin-universal
Install: wbt-virtualmin-nuvola-chocmint.noarch 0:1.226-1 - virtualmin-universa l
Install: wbt-virtualmin-nuvola-dusk.noarch 0:1.226-1 - virtualmin-universal
Install: wbt-virtualmin-nuvola-green.noarch 0:1.226-1 - virtualmin-universal
Install: wbt-virtualmin-nuvola-pushup.noarch 0:1.226-1 - virtualmin-universal
Install: wbt-virtualmin-nuvola-raspberry.noarch 0:1.226-1 - virtualmin-univers al
Install: webmin.noarch 0:1.230-1 - virtualmin-universal
Total download size: 27 M
Downloading Packages:
unsigned package virtualmin-base-1.0-14.noarch.rpm
Installation failed: 1
Removing virtualmin-release package, so that installation can be re-attempted
after any problems reported are resolved.

Wed, 10/12/2005 - 01:25
ADobkin

I'm still having the same problem also. I've done a yum clean all, as recommended per[A HRef="http://www.virtualmin.com/bug-tracker/bug?bug%5fnumber=81">Bug #81</A>, but that did not resolve the problem. It looks like it is still unsigned at the sorurce.

Wed, 10/12/2005 - 12:47 (Reply to #6)
ADobkin

FYI, I just did a yum update, and it worked fine for me. The unsigned virtualmin-base package problem has been resolved:

<BlockQuote>
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package virtualmin-base.noarch 0:1.0-14 set to be updated
--> Running transaction check

Dependencies Resolved
Transaction Listing:
Update: virtualmin-base.noarch 0:1.0-14 - virtualmin-universal
Total download size: 11 k
Is this ok [[y/N]]: y
Downloading Packages:
(1/1): virtualmin-base-1. 100% |=========================| 11 kB 00:00
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Updating: virtualmin-base 100 % done 1/2

Updated: virtualmin-base.noarch 0:1.0-14
Complete!
</BlockQuote>

As to the depency issue, my only suggestion is that you download and install the Webmin and Usermin RPMs from the main Webmin site. Normally, you shouldn't have to do this, but it should be an acceptable workaround for this bug until Joe responds with the official resolution.

Alan

Wed, 10/12/2005 - 03:35
Joe
Joe's picture

Argh. Package signatures are going to be the death of me.

I think it's fixed now, but I'm going to do a test install here just in case before I assure you of it.

--

Check out the forum guidelines!

Wed, 10/12/2005 - 08:30
FaisalMehmood

Now i have missins dependencies. I thought the installer setup Webmin itself. I didn need to do it beforehand !! :(

Error: Missing Dependency: usermin]= 1.160 is needed by package virtualmin-base
Error: Missing Dependency: webmin]= 1.230 is needed by package virtualmin-base
Installation failed: 1
Removing virtualmin-release package, so that installation can be re-attempted
after any problems reported are resolved.

:(:(:(

Wed, 10/12/2005 - 08:56
FaisalMehmood

Is there any manual way i can install Virtualmin Pro ? :(

Still getting :

--> Running transaction check
--> Processing Dependency: usermin]= 1.160 for package: virtualmin-base
--> Processing Dependency: webmin]= 1.230 for package: virtualmin-base
--> Finished Dependency Resolution
Error: Missing Dependency: usermin]= 1.160 is needed by package virtualmin-base
Error: Missing Dependency: webmin]= 1.230 is needed by package virtualmin-base
Installation failed: 1
Removing virtualmin-release package, so that installation can be re-attempted
after any problems reported are resolved.

Wed, 10/12/2005 - 12:38
FaisalMehmood

Someone please update on this :( i need to get my server up and running soon.

Thanks.
Faisal.

Wed, 10/12/2005 - 13:40
FaisalMehmood

Hey alan. Did you have the Usermin and Webmin pre-installed ? Why didnt you get the dependency issue ?

I am probably going to get the webmin and usermin through yum. That should fix it i suppose. And they would be signed too. although still am skeptical if this would break the system somehow. Ahh well lets give it a try anyways :)

Wed, 10/12/2005 - 14:05 (Reply to #12)
ADobkin

Yes, I already had all of Virtualmin Pro EA1 installed. I was only getting the updated virtualmin-base package, so my problem was resolved once the package was signed.

However, the webmin and usermin versions from www.webmin.com are exactly the same as the ones in Virtualmin Professional, so you can download those separately and that should fix your dependency problem. It will not break the system to have them installed manually, as long as you don't install the Virtualmin GPL version.

Wed, 10/12/2005 - 14:27
FaisalMehmood

am i jinxed ???? :(

(1/4): virtualmin-base-1. 100% |=========================| 160 B 00:00
http://software.virtualmin.com/universal/virtualmin-base-1.0-14.noarch.rpm: [[Errno -1]] Package does not match checksum
Trying other mirror.

Error Downloading Packages:
virtualmin-base - 1.0-14.noarch: failure: virtualmin-base-1.0-14.noarch.rpm from virtualmin-universal: [[Errno 256]] No more mirrors to try.

Wed, 10/12/2005 - 14:36
FaisalMehmood

Ok. its installed. :) .... finally !!!

Wed, 10/12/2005 - 18:05
Joe
Joe's picture

Apologies for all of the installation troubles. I made some updates to fix some bugs that Alan and others have reported, but it seems like everything that could go wrong did. ;-)

When you get the error about a header mismatch, it just means yum has outdated information. A "yum clean headers" will fix it. The package header without a signature was still cached on your system...and so it doesn't match the checksum for the same package with a signature. I should have bumped the revision on that package, instead of just re-signing it.

The Webmin and Usermin problem was just a problem with the mirrored packages from Webmin.com--I guess the mirror I grabbed them from wasn't complete at the time when I got them...whatever the cause, we ended up with corrupt RPMs. Fixed now.

As far as I know there were just the two problems...They're just particularly annoying because of yums caching of headers (which is a good thing, when everything is working right in the repositories).

--

Check out the forum guidelines!