PreSales? - Virtualmin Pro on new LAMP

4 posts / 0 new
Last post
#1 Thu, 10/20/2005 - 14:59
MarkMollenkopf

PreSales? - Virtualmin Pro on new LAMP

I've spent the last couple days building a new LAMP system and am thinking about adding the Virtualmin Pro-50 to it. I like the idea of being an Early Adopter and in some small way paying you guys back for the great work on Webmin! Here's what I've got:

FedoraCore3 Apache 2.0.55 PHP 5.0.5 MySQL 4.1.14 Webmin 1.240 Virtualmin 2.604 15 available IP's 207.xx.xx.113 and 72.xx.xx.1 - 72.xx.xx.14

Ideally I'd like to configure Virtualmin Pro with Namebased sites on the 207. address and IP Based sites (w/ SSL) on the 14 72. addresses.

I was trying out the GPL version this afternoon and was able to setup a virtual account OK but then Apache failed with an error related to suexec. -Failed to stop Apache: Syntax error on line 1320 of /usr/local/apache2/conf/httpd.conf: Invalid command 'SuexecUserGroup', perhaps mis-spelled or defined by a module not included in the server configuration

I'm assuming that I'll need to recompile Apache using --enable-suexec --with-suexec-docroot=/usr/local. (I'll google around a little and look for a HowTo to see if I'm missing another --with )

1) Anything else that the Pro version is going to need?

2) Any problem with have both namebased and IP based sites/accounts running through Virtualmin?

3) I read through most all of the forum entries and saw some comments about transitioning from GPL to PRO, is my best bet to delete the current Virtualmin module and then install the PRO? Or is there more that will need to be cleaned up?

4) Please excuse the following Newbie question - when I recompile Apache will I also need to so for PHP?

Thanks in advance, Mark

Thu, 10/20/2005 - 15:37
Joe
Joe's picture

Hi Mark,

Yep, you'll need SuExec (though I think it is still possible to disable it in Virtualmin, I don't recommend it). We use a suexec-docroot of /home, because that's where our quotas get setup, our Maildirs get sent, and much more.

To answer your numbered questions:

1. The Pro version is going to want to install everything for you from scratch--at least for the next week or two until I've had time to complete the "naked" installation mode, where it just installs our modules and leaves everything else up to you. This will also be how upgrades from GPL work in the short term, since there's no way for us to accomodate migration from the practically infinite possible mail server options, mail delivery options, spam/AV options, file locations, build settings, configurations, etc. Don't try to upgrade from GPL to Pro with the current installer. It will either fail (assuming your current system is mostly installed from RPMs) or break things, possibly badly (assuming your system is installed from tarballs).

2. Probably not. I know Jamie had a discussion with someone about this not more than a month ago, and I'm pretty sure the capability to deal with both is in both the most recent Pro and GPL versions (but maybe not GPL yet...not sure).

3. Pro currently expects a fresh OS install, not just no Virtualmin module. The Pro installer does <i>everything</i> for you. There will soon be an install mode that only installs our components and leaves everything else up to you. This mode does not yet exist.

4. No. Though the mod_php might need a rebuild, if you use it (I'm not sure what causes one to need a rebuild...but I imagine moving things around, adding modules that effect PHP, etc.). In a virtual hosting environment, however, FastCGI is probably the better way to go as it is about as fast and supports SuExec.

Hope this helps with your plans.

--

Check out the forum guidelines!

Thu, 10/20/2005 - 15:16
MarkMollenkopf

To save you some typing, I just found the bit about

--with-suexec-docroot=/home

in the Support Docs. Plus adding LoadModule suexec_module modules/mod_suexec.so to my httpd.conf.

thx. Mark

Thu, 10/20/2005 - 17:10
MarkMollenkopf

Hi Joe,

Thanks for the quick response... that helped me get a better handle on it.

I got excited about Virualmin when I realized that I could kill off my Ensim box down at ValueWeb, and replace it with an almost completely open source solution. My new box is still at VW, but just a standard FC3 with any commercial control panel.

1) if I decide to get brave, how hard will it be to wipe this box and prep it for Pro? There no data, just the freshly installed (from source, not rpm) programs mentioned previously.

1a) Not so Brave option - am I better off paying somebody to do a fresh remote install of FC or CentOS or Slackware, and then install PRO? If so, can you recommend anyone, or can I add a couple support incidents to my shopping cart along with my PRO-50 and you'll just make it all work. ( I think my wife is getting tired of seeing me beat my head on the desk and she'd be happy if I paid for a little help once in a while.)

2) Will PRO install PHP 5.0.x and MySQL 4.1.x ? I'm looking at this move as a chance to get away from Ensim's 2-3 year old versions, running on FC1 that they don't let you patch.

3) I'm guessing that you guys are using a PHP that has most of the goodies built-in to an rpm. The only thing I was looking for above an beyond the standard GD/JPG/PNG was starting to utilize one of the PDF libs.

Thanks, Mark

PS: I liked your posting about the 7 programmers... you guys are GR8! I'm looking forward to being a customer and supporter.