Third-party scripts

6 posts / 0 new
Last post
#1 Sat, 11/26/2005 - 21:13
Blueforce

Third-party scripts

Hi, Almost all provided third-party scripts require PHP4 and I run FC4 which is provided with PHP5. Can I have both versions installed without running into problems and conflicts. I have read in some other post that you can choose which PHP version to run...How do I do that?? I dont want to mess upp my new server installation so I would appreciate some guidelines how to get things running. In some other post I read that after installing PHP4 on FC4/PHP5 the PHP didn't function at all. I really need some of the script to work before I can move all our customers to our new server.

Best regards Leif Blåfors Sweden

Sun, 11/27/2005 - 01:16
Joe
Joe's picture

Hi Leif,

I'm still working on the PHP version selection...Hopefully, it will come in the next couple of days.

In the short-term I'll look further into the PHP4+PHP5=neither works problem, as that is a roadblock to getting the switchable PHP version code working, anyway...and it prevents folks from being able to even use most of the scripts. Hopefully, I'll have a solution to that problem in the next 24 hours.

--

Check out the forum guidelines!

Sun, 11/27/2005 - 10:14
Blueforce

Hi Joe,
Thank you, I'm looking forward to the next post and hopefully the PHP4/PHP5 solution.

Thanks again, and keep up the good work!

Regards,
Leif Blåfors

Tue, 11/29/2005 - 17:30
Blueforce

Hi Joe,

I wonder if you have found a solution to the PHP4/PHP5 problem.

Regards
Leif Blåfors

Tue, 12/27/2005 - 04:50
Joe
Joe's picture

I just noticed this post hanging around seemingly unanswered, and so I'm adding a link to the FAQ about this problem:

http://www.virtualmin.com/faq/one-faq?faq_id=1511#16765

--

Check out the forum guidelines!

Tue, 12/27/2005 - 19:06
Blueforce

Hi Joe!
Actually you did answer this in another post i did "Third-party scrips, Again" 12/04/05. I allso did a post in the Bug Tracker (#153) and the state of the post is still "open". I really think the info posted by Chris Blackwell in the forum, and your guideline in FAQ on how to switch to PHP4 resolved this problem. So maybe you could change the state for Bug #153 to resolved so you or I can close it.

BTW, our server now works like a charm, and the new framed theme... it's very cool and easy to navigate, nice work!

Regards
Leif Blåfors
Sweden