PHP-FPM support was not detected : No FPM configuration directory found

15 posts / 0 new
Last post
#1 Mon, 02/27/2017 - 12:45
clouseau
clouseau's picture

PHP-FPM support was not detected : No FPM configuration directory found

As I can see, with the new version there came php-fpm support. I have installed php-fpm (rh) but when I do a re-check configuration, it says like in the subject line.

I have actually used the default dir for the config, where the original www.conf is placed. Any idea where chould I put the config file for this to work?

Best, Istvan

Mon, 02/27/2017 - 17:35
Joe
Joe's picture

Are you using an alternate PHP version from the default for your OS? If so, which one? Support is pretty early and labeled beta right now, so the amount of testing it's had across various PHP versions is very low. We rely on folks to let us know what they're using and where things are located, if not the standard location. (That said, I think it's been tested with the SCL versions of PHP, in addition to the standard package. But others maybe not.)

--

Check out the forum guidelines!

Tue, 02/28/2017 - 07:55 (Reply to #2)
clouseau
clouseau's picture

Thanks for the comment. I've installed multiple PHP versions from this documentations: https://www.virtualmin.com/documentation/web/multiplephp

So, I have also installed to try, rh-php70-php-fpm, set up a pool on config in it's default php-fpm.d dir, even started it but Virtualmin still says no fpm config detected when re-check the config.

Thu, 03/02/2017 - 08:48
clouseau
clouseau's picture

Where does Virtualmin expect me to put some conf file (the pool conf I guess) so it could detect it?

Thu, 03/02/2017 - 08:54
clouseau
clouseau's picture

Is there just any documentaion on this? Maybe I could be of help...

Thu, 03/02/2017 - 09:22
Pathways

I'm using PHP 7.1.2 from deb.sury.org with Debian 8.7 . Webmin lists php7.1-fpm in System>Bootup and Shutdown as one of the services that can be selected to be automatically started. However, Virtualmin does not detect it in System Settings>Re-check Configuration so it reports "PHP-FPM support was not detected : No FPM server bootup action found", which is not correct.

Sat, 05/13/2017 - 23:46 (Reply to #6)
CEEWorld

THE FOLLOWING ASSUMES THE REMOVAL OF PHP5.6

On debian8 Jessie you are best using the dotdeb repository as it contains up to date files for jessie

To add the repo use the following code:

$ sudo -s
# echo 'deb http://packages.dotdeb.org jessie all' >> /etc/apt/sources.list
# echo 'deb-src http://packages.dotdeb.org jessie all' >> /etc/apt/sources.list

Then add the key

$ cd /tmp
$ wget https://www.dotdeb.org/dotdeb.gpg
$ sudo apt-key add dotdeb.gpg
$ rm dotdeb.gpg
$ sudo apt-get update

You can then install the required packages

$ sudo apt-get install php7.0 php7.0-fpm

Make sure that you have enabled php7.0-fpm conf file

$ sudo a2enconf php7.0-fpm

enable any required apache2 or configure nginx mods for your distro

Hope it helps

Wed, 03/22/2017 - 08:04
gonzaloalonsod

Any solution to use php 5.6 and 7 on debian 8?

Wed, 03/22/2017 - 11:08
sfatula

I had the same issue with multiple php. Kind of wondered about that since it only uses based on your command line settings (scl), so, how would it know what to use for FPM? So, I decided against SCL since I was using a new machine to configure anyway (will migrate stuff over) and therefore, went with remi repo for php7.1. Virtualmin detects FPM and all works fine. Maybe it's looking for certain binaries (despite the message)?

When using remi repo on Centos 7, fpm is /etc/php-fpm.conf and /etc/php-fpm.d if that helps.

Tue, 04/04/2017 - 17:32
robbrandt

I am having this issue too. New Ubuntu 16.04 installation on Amazon, after installation of Virtualmin I removed php 7 and installed php 5.6 from ondrej/php. Everything else on my recheck configuration is OK.

Sat, 05/13/2017 - 22:20
pratam02

Hello Team,

Today i installed the fresh installation of OS and Virtualmin. (running with latest version) ubantu 16.04 lts virtualmin 5.07

everything went well. once i logged into virtualmin and pressed -> re-check configuration" i got below error. "PHP-FPM support was not detected : No FPM configuration directory found"

I am not added or removed any php versions (everything is default as per the installation guide)....

I am not sure where i have to do changes, please suggest the steps to fix this error.

Regards

Sat, 05/13/2017 - 23:09
CEEWorld

Whilst Ubuntu will use and install php-7.0, php7.0-fpm is not usually installed by default. You need to make sure that php7.0-fmp is installed and the relevant apache2 library.

Use the following code via command line for Ubuntu 16.04

apt-get install libapache2-mod-fastcgi php7.0-fpm

Once installed try re-checking your configuration and see if the issue is solved.

Hope it helps.

Thu, 09/07/2017 - 17:52
DarkSoroush

It seems that the Webmin checks for the php-fpm service. However, I had "rh-php70" installed so it didn't recognize it. What I did was simply to create a link to the right service unit file.

yum remove php-fpm yum install rh-php70-php-fpm cd /etc/rc.d/init.d ln -s "rh-php70-php-fpm" "php-fpm" service php-fpm restart

You might also want to do this to make php-fpm use the correct configuration files created by VirtualMin:

cd /etc/opt/rh/rh-php70 mv php-fpm.d php-fpm.d.old ln -s "/etc/php-fpm.d" "php-fpm.d" service php-fpm restart

Obviously not the best thing to do, but it makes Webmin detect this version.

Fri, 10/27/2017 - 02:27
clouseau
clouseau's picture

Is there some official support for php-fpm and multi php versions from VM now?

Thu, 09/06/2018 - 17:03
jbatun21564065
jbatun21564065's picture

I am using a configuration of running centos 7 with this kernel Linux 3.10.0-862.11.6.el7.x86_64 # 1 SMP x86_64 x86_64 x86_64 GNU / Linux

The FPM packages installed on machine is

rh-php56-php-fpm.x86_64 5.6.25-1.el7 @ centos-sclo-rh AND rh-php71-php-fpm.x86_64 7.1.8-1.el7 @ centos-sclo-rh

the two FPM servers are running one on port 9000 to 5.6 and on other port 9900 to 7.1, but when I re-check the configuration, Webmin displayed the messages, " can not detect the FPM mode".

How can I solve it? some help, with this problems. I will appreciate your help.