Can't find docroot for subdomain

3 posts / 0 new
Last post
#1 Tue, 01/17/2006 - 20:54
AlisonGianotto

Can't find docroot for subdomain

Hi all (and hi Joe!)

I added a subdomain for a site, say new.mydomain.com, using virtualmin and clicking on the "Add sub-domain" option. All looked to be well, and the dir /home/myuser/domains/new.mydomain.com/ was created. Accessing new.mydomain.com from a browser resolved immediate, so I began uploading to /home/myuser/domains/new.mydomain.com/public_html/

When I access a known directory, such as new.mydomain.com/foo/index.php, it says file not found, and despite the fact that there is a valid index file in the docroot, the default page never goes away. It's as if apache is looking somewhere other than /home/myuser/domains/new.mydomain.com/public_html/ for the files, as it is behaving as though that public_html dir is empty.

Any ideas?

Wed, 04/26/2006 - 15:44
AlisonGianotto

Ran into this problem again - did anyone have an answer?

Thu, 04/27/2006 - 03:10
Joe
Joe's picture

Hey Alison,

Can you post the VirtualHost section of /etc/httpd/conf/httpd.conf for this subdomain? I'm not seeing an immediate cause for this behavior, and it works fine when I create a subdomain on the demo server and drop an index.html or index.php file in place in a subdirectory within that domain.

Seems like I recall there was some issue with subdomains a while back...are you using the latest version? I believe there was an issue with the default server template for subdomains not containing a DocumentRoot. Which would give the behaviour you're seeing.

--

Check out the forum guidelines!