[LetsEncrypt] working but no output on screen + failure e-mails every 3 minutes

2 posts / 0 new
Last post
#1 Wed, 04/19/2017 - 20:21
ladhani

[LetsEncrypt] working but no output on screen + failure e-mails every 3 minutes

Hi,

After I have filled in the Let's Encrypt form (Server Configuration -> Manage SSL Certificate -> Tab Let's Encrypt) and click on 'Request Cerfificate', nothing seems to happen. I only see a message:

"Requesting a certificate for [hidden] from Let's Encrypt .."

Nothing happens next (always and persistent).

However, most of the times, if I check the SSL certificates after 10-20 minutes or so, the Let's Encrypt Cerficate has been made and is correctly installed.

So somehow on the background the request process has managed to complete. But all I am seeing on my browser page in VirtualMin:

"Requesting a certificate for [hidden] from Let's Encrypt .."

Forever......

Is it possible to somehow reset or re-install the Let's Encrypt part in VirtualMin for Centos 6.5?

Thanks!

Thu, 04/20/2017 - 11:35
ladhani

Follow up:

I am now getting every 3 minutes mails (although SSL has been installed correctly):

Let's Encrypt certificate renewal failed!

I tried to set renewal to manual via Manage SSL Certificates -> tab Let's Encrypt -> Only renew manually -> button Only Update Renewal.

However, the mails for this domain do not stop....

1 - Where can I find the Let's Encrypt configuration files on VirtualMin Centos 6.5? They are not in /etc/letsencrypt (which would be what I expected).

2 - And what is the name of the cron job used by VirtualMin for Letsencrypt auto updates?

3 - Is there a way to reset / re-install clean the letsencrypt part in VirtualMin? It would not be an issue for me to start clean as I used this machine to test letsencrypt first on VirtualMin 5.07gpl on Centos 6.5.

Thanks!

Here is a copy of the non-stoping e-mails every 5 minutes.

=================================================

An error occurred requesting a new certificate for [hidden] from Let's Encrypt : Failed to request certificate :

Parsing account key... Parsing CSR... Registering account.. . Already registered! Verifying [hidden]... [hidden] verified! Traceback (most recent call last): File "/usr/libexec/webmin/webmin/acme_tiny.py", line 203, in main(sys.argv[1:]) File "/usr/libexec/webmin/webmin/acme_tiny.py", line 199, in main signed_crt = get_crt(args.account_key, args.csr, args.acme_dir, log=LOGGER, CA=args.ca) File "/usr/libexec/webmin/webmin/acme_tiny.py", line 150, in get_crt os.remove(wellknown_path) OSError: [Errno 2] No such file or directory: '/home/[hidden]/public_html/.well-known/acme-challenge/gZRPLdRLGe9clr_cyUEPaViwQWNg1tW2KTjhH-tFV4M'